Paused and then Resumed SIM no longer works

I have some GL7500 modems and a hologram SIM card. Initially, it was working but as a test I “paused” the sim and sure enough, the modem was no longer able to register (+CxREG: 3 -> denied). So I clicked “resume” for the sim and tried for a long time to get that modem to work again and it just wouldn’t - same registration denied state.
I thought I’d try another GL7500 modem and that one worked. So I thought, lets try this again - paused it, then resumed and now that modem still can’t register.

So my question is, is there some problem with “pausing” sim cards? It seems to blacklist whatever modem was using it when the pause occurred. Yet a new fresh modem can use the card.

did you power cycle the modem?

Yes. Both modems have been powered up, down and swapped. Whatever happened when ‘pausing’ the sim seems to be permanent to the modem. The sim still works with a 3rd modem. The carrier the SIM uses here is Rogers Wireless (Canada).

Seems like something has been fixed - we’re back in business and were able to a subsequent pause->resume with success.

Sounds like something with that modem where it blocks after a failure for a set period of time. Most modems will reset that after a restart but it must be saving it to permanent memory somewhere.