PDP activation failure after registering to a different network


Hello there,

I am using a Hologram SIM to set up a TCP connection on a third party AT command LTE device.It was working just fine. I both send and received data using the SIM and the simple gui using the Hologram dashboard, it worked flawlessly. However after some days of not using it I connected again and it certainly got registered to the network(doubled checked by AT+COPS?), however I noticed it hooked to another service provider in my country this time. Previously it was working with At&T hologram and now with Telcel Hologram.

I haven’t been able since then of sending data. The issue comes when trying to activate the PDP context. I set it up as before using hologram APN and proper configuration (which worked before) and after a couple of seconds, it returns an error code, so it seems like is trying to connect but the connection is refused. If i try other APNs an error occurs immediatly so yeah I think this is where the error is.

Going throught your forum I found similar issues but they were resolved in your end. So itd be very kind of you if you could provide me with some aid or any type of info on this.

In the meantime I will keep trying but I am pretty much at loss because I really did nothing different than before.

In the dashboard the SIM says it’s live.

Thanks a lot.


Okay i will post more details as no response yet.

Current Log

[2019-03-15 10:00:10:343_S:] AT+CPIN?
[2019-03-15 10:00:10:350_R:] AT+CPIN?
[2019-03-15 10:00:10:350_R:] +CPIN: READY

[2019-03-15 10:00:10:350_R:] OK

/* Use AT+CSQ to query current signal quality */
[2019-03-15 10:00:10:610_S:] AT+CSQ
[2019-03-15 10:00:10:622_R:] AT+CSQ
[2019-03-15 10:00:10:622_R:] +CSQ: 16,99

[2019-03-15 10:00:10:622_R:] OK

/* Use AT+CREG? /AT+CGREG? to query the network registration status. */
[2019-03-15 10:00:10:624_S:] AT+CREG?
[2019-03-15 10:00:10:638_R:] AT+CREG?
[2019-03-15 10:00:10:638_R:] +CREG: 0,5

[2019-03-15 10:00:10:638_R:] OK
[2019-03-15 10:00:10:640_S:] AT+CGREG?
[2019-03-15 10:00:10:653_R:] AT+CGREG?
[2019-03-15 10:00:10:653_R:] +CGREG: 0,5

[2019-03-15 10:00:10:653_R:] OK

/* Use AT+COPS? to query current Network Operator */
[2019-03-15 10:00:10:743_S:] AT+COPS?
[2019-03-15 10:00:10:749_R:] AT+COPS?
[2019-03-15 10:00:10:749_R:] +COPS: 0,0,“TELCEL Hologram”,0

[2019-03-15 10:00:10:766_R:] OK

/Use AT+CEREG? to query current EPS Network Registration Status/
[2019-03-15 10:00:10:848_S:] AT+CEREG?
[2019-03-15 10:00:10:862_R:] AT+CEREG?
[2019-03-15 10:00:10:862_R:] +CEREG: 0,4

[2019-03-15 10:00:10:862_R:] OK

So as you can see the SIM is working and it is registered to a network.

Previous (when it was working) log:

/* Use AT+CPIN? to query the SIM card status : SIM card inserted or not, locked or unlocked */
[2019-03-01 13:02:24:235_S:] AT+CPIN?
[2019-03-01 13:02:24:235_R:] AT+CPIN?
[2019-03-01 13:02:24:250_R:] +CPIN: READY

[2019-03-01 13:02:24:250_R:] OK

/* Use AT+CSQ to query current signal quality */
[2019-03-01 13:02:24:516_S:] AT+CSQ
[2019-03-01 13:02:24:532_R:] AT+CSQ
[2019-03-01 13:02:24:532_R:] +CSQ: 17,99

[2019-03-01 13:02:24:532_R:] OK

/* Use AT+CREG? /AT+CGREG? to query the network registration status. */
[2019-03-01 13:02:24:532_S:] AT+CREG?
[2019-03-01 13:02:24:547_R:] AT+CREG?
[2019-03-01 13:02:24:547_R:] +CREG: 0,5

[2019-03-01 13:02:24:547_R:] OK
[2019-03-01 13:02:24:547_S:] AT+CGREG?
[2019-03-01 13:02:24:563_R:] AT+CGREG?
[2019-03-01 13:02:24:563_R:] +CGREG: 0,5

[2019-03-01 13:02:24:563_R:] OK

/* Use AT+COPS? to query current Network Operator */
[2019-03-01 13:02:24:656_S:] AT+COPS?
[2019-03-01 13:02:24:672_R:] AT+COPS?
[2019-03-01 13:02:24:672_R:] +COPS: 0,0,“AT&T Hologram”,0

[2019-03-01 13:02:24:672_R:] OK

/Use AT+CEREG? to query current EPS Network Registration Status/
[2019-03-01 13:02:24:766_S:] AT+CEREG?
[2019-03-01 13:02:24:766_R:] AT+CEREG?
[2019-03-01 13:02:24:781_R:] +CEREG: 0,4

Commands used both previosuly and currently:

[2019-03-15 10:21:02:295_S:] AT+QICSGP=1,1,“HOLOGRAM”,"","",0
[2019-03-15 10:21:02:309_R:] AT+QICSGP=1,1,“HOLOGRAM”,"","",0
[2019-03-15 10:21:02:325_R:] OK

/* Query the status of the context profile */
[2019-03-15 10:21:02:327_S:] AT+QIACT?
[2019-03-15 10:21:02:341_R:] AT+QIACT?
[2019-03-15 10:21:02:341_R:] OK

/* Activate context profile */
[2019-03-15 10:21:02:345_S:] AT+QIACT=1
[2019-03-15 10:21:02:356_R:] AT+QIACT=1
[2019-03-15 10:21:07:794_R:] ERROR

/* Query the status of the context profile */

[2019-03-15 10:21:07:798_S:] AT+QIAC

[2019-03-15 10:21:07:810_R:] AT+QIACT?
[2019-03-15 10:21:07:810_R:] OK

/* Close the context */
[2019-03-15 10:21:09:490_S:] AT+QIDEACT=1
[2019-03-15 10:21:09:505_R:] AT+QIDEACT=1
[2019-03-15 10:21:09:505_R:] OK


Okay, so I conotacted Hologram team and they provided me with an useful link where I could dig deeper on what the issue was.

When running AT+COPS=? I got a list of network providers, the one my device was automatically registering to wasn’t working for me so I switched to another one and that solved the issue.

closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.