PSM Mode on Rogers Network (Canada)


I am using a Thingy:91 on the Rogers network in Canada, and it cannot enable PSM mode. Do you know anything about why this would be the case? IP connectivity is fine otherwise.

Here is the ticket I opened with Nordic Getting started with the Thingy:91 - Nordic Q&A - Nordic DevZone - Nordic DevZone



Nothing really to do with Hologram.I believe the physical carrier must support PSM as well, its possible Rogers does not. I believe there is an AT command to query the PSM settings provided by the network (I know there is for the U-Blox LTE-M1 modules). That would be your best bet to check on the device, or google searching for PSM support on rogers LTE-M1 but that is pretty obscure so you may have to hunt alot for it.

Thanks Andrew,

It is indeed obscure.

I wonder if people with other hardware have run applications using PSM on the Rogers network in Canada.


It does look indeed that Rogers does not support PSM on roaming Hologram cards. I was able to query the PSM settings for the network. This is a Hologram issue in my opinion, Hologram should find a roaming partner that does support it, or work it out with Rogers.

Has there been any changes since Sep '19?
I’m having the same issue, it looks like my modem (nrf9160 DK) is not going to sleep for long periods… This is interrupting the GPS fix (since the modem shares the Antenna for LTE-M and GPS) and also causes higher power consumption.

I agree with calinm that Hologram should negotiate this with the MNOs, or else it will make LTE-M pretty useless in some cases, low power is one of the main advantages of LTE-M and if no PSM/eDRX that could be a deal breaker for many applications.

Also @calinm did you find a command to check and confirm if the modem can observe LTE-M support from the network?


See here: Getting started with the Thingy:91 - Nordic Q&A - Nordic DevZone - Nordic DevZone

+CEREG: 5,5,“8980”,“061B8B0B”,7,“11100000”,“11100000”
The meaning of the values can be found in 3GPP TS 24.008, section, but long story short, when they start with “111” the timers are not active, i.e. you do not have PSM activated.

It doesn’t work when roaming on the Rogers network. It does work if you get an IOT account with Telus

Can still confirm that PSM still doesn’t work on Rogers Hologram. Pls fix.

Using a Rogers SIM on the Rogers network, my module enters PSM after 150 seconds of inactivity, however when I wake it the carrier connection is lost. I have to reboot the module and reconnect to network to transfer any data (defeats the purpose).

Not sure if this means Rogers doesn’t support it or I’m doing something wrong with how I wake it.

Using a SIM7000 module (Botletics shield). Haven’t tried hologram yet.

Hi Guys,
late to the party. I have been testing Hologram SIMs with nrf9160 in Canada. The SIMS typically connect to Telus or Bell but i am not able to enter PSM either. Using a bell sim, PSM works just fine and I can sleep for hours on end but with Hologram SIMs, PSM is not entered. Querying CEREG, I get “11100000”, where 111 means PSM is not granted by the network.

This is a downer really as coverage is great with the Hologram SIMs but no PSM is a deal breaker.