Pycom FiPy compatibility

Does anybody know if Pycom device FiPy with Expansion Board will work on the U.S. West Coast (4G LTE T-Mobile). I have seen a list of hardware/devices somewhere on a github that I cannot find anymore and this device was not in the list. But at the same time I don’t know if that list is really maintained and accurate. If FiPy is not working in my region what other device I can get that also have WiFi in addition to CAT-M1. Some decent development environment, preferably in MicroPython would be great too…

We don’t have any experience with the FiPy or the Expansion Board, but we do have the Pycom GPy working on AT&T Cat-M1 across the USA (including +50 installations in northern California, 1 in Nevada, and a couple in Washington state). We are not using the WiFi capability of the GPy, but don’t see any reason that it would not also work.

Thank you. By this time I already managed to get data to Hologram using FiPy mounted on PySense Expansion Board 3.0 (that has environmental sensors) over CAT-M1. Interesting to note that I did not indicate in the firmware what provider to use knowing that Verizon is the default (I think), and indeed the first connection it made was with Verizon…but since then it constantly chooses AT&T.


I had my FiPy board connecting and sending data and then it simply stopped working. It hasn’t connected in 11 days now and I’ve tried many different thing to attempt to get reconnected.

Do you have an example working configuration for the modem?



I use the same code that worked before for initialization of LTE-M and then sending data to Hologram from FiPy sitting on PySense 3.1. The interesting part is that I send the data in the 1st call to lteSocket.send and then trying to read lteSocket.recv(8) and it just gets stuck on this call. It made me to put a timeout on the socket but neither 2 sec or 10 sec did not make a difference and neither how many bytes I tried to read…I also tried non-blocking and blocking socket - did not matter either.

On the Hologram side I do not see the data from that first send immediately, and not even after minutes, not sure how long it takes for the data to appear there, but I can see it after hours, and it is only part of the data that I see. If I send 200 tuples I can only see maybe 15.

Anyway, very strange behavior. Hologram might be broken. I will not waste my time on it anymore…There are other options, especially since I need to visualize data in a chart, something the Hologram cannot do. There is a free IoT platform ThingsBoard - free and open source with amazing visualization capabilities and I will try pushing data to it directly either with HTTP or MQTT. I just need to decide how much data I deliver in one shot since I generate a tuple every 4-5 msec so it becomes a lot of data quickly and I am not sure how much MQTT can handle in one call.

Hi Jason,
Try running through these guides: