Python SDK Install Error


#1

Hello,

I have a custom version of yocto linux running on a BBB and I am trying to get all the dependencies for the SDK correct. When I run curl -L hologram.io/python-install | bash I get the following errors:

root@beaglebone:~# curl -L hologram.io/python-install | bash
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 178 100 178 0 0 696 0 --:–:-- --:–:-- --:–:-- 698
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
100 3450 100 3450 0 0 926 0 0:00:03 0:00:03 --:–:-- 1325
Linux system detected
Reading package lists… Done
python is already installed.
ps is already installed.
kill is already installed.
Reading package lists… Done
Building dependency tree… Done
E: Unable to locate package libpython2.7-dev
E: Couldn’t find any package by glob 'libpython2.7-dev’
E: Couldn’t find any package by regex ‘libpython2.7-dev’

As you can see I have libpython installed:

root@beaglebone:~# dpkg -l | grep libpython
ii libpython2.7-1.0 2.7.13-r1 armhf The Python Programming Language
ii libpython3.5m1.0 3.5.3-r1.0 armhf The Python Programming Language

Any advice would be helpful. Is it a path issue? Has anyone seen this before?

Regards,


#2

Hi, it looks like your OS uses different package names than Raspbian so that script won’t work. What you can try instead is to make sure you have python and pip installed and then run:
sudo pip install hologram-python


#3

Excellent, worked great!

Regards,


#4

I am able to send messages to the cloud, and they are successful; however, I always get the following message:

No handlers could be found for logger "pyroute2.netlink.rtnl.tcmsg.common"
RESPONSE MESSAGE: Message sent successfully

Another example:
root@beaglebone:/home/debian# hologram modem signal
No handlers could be found for logger "pyroute2.netlink.rtnl.tcmsg.common"
Signal strength: 25,2

Should I be concerned?

Regards,


#5

It’s possible you have a different python routing library and we’re not catching the log messages from it. It’s nothing to worry about but can you file an issue on our github for that error? https://github.com/hologram-io/hologram-python