R404 issues


#1

In R404 Not working (enumeration and power brown out) @ryanHologram mentions “Our conversations with u-blox and further testing continue to show that the R404 is not ready for prime time production scenarios”. Are there issues other than the re-enumeration stuff?

Also, I’m puzzled by the continuous mentions of power consumption. The R404 and R410 are LTE-only and they power consumption is actually pretty darn low! Is this just because you guys can’t keep 3G and LTE Cat-1M apart?

Specifically, the R404 and R410 accept Vcc in a wide range (3.2V-4.2V) and the peak current during TX is 490mA, avg max being 190mA. A 400mV voltage drop is allowed during TX. This should not be that much of a burden on an rPi unless you’re running the rPi itself very hot at the same time (unlikely when people are testing as in the mentioned thread). Note that when using 2G (not avail on the R404/R410) the peak TX current is 1.9A, yowza!


#2

In my testing, the R404 was incredibly unreliable to get to start. I have a Pi Zero without wireless, and a Zero4U USB expansion board that draws power straight from the 5V rail to get around the current limit on the Pi Zero’s OTG port. Using a generic charger I could never get the board to start. Once I had an official Pi charger, I could sometimes get it to start, and if it actually started I could sometimes get it to enumerate. What made this incredibly frustrating is that, as other users here have mentioned, for some strange reason the R404 will be wholly incapable of booting up after being powered down until several minutes have passed. So if it fails to boot, it means you have to wait 5 minutes or so before trying again. And even if it does boot up successfully and enumerate, you only have until you shut everything off before that ceases to be the case.

So, from my independent testing, I would agree with the assertion that it does not appear ready for prime time. I would love to trade up to the R410 (which wasn’t available when I joined Hologram) to see if it has solved these problems. I’ve sent a support e-mail saying as much, but haven’t heard a response yet. Here’s hoping!


#5

My question was actually more about issues other than the re-enumeration and initialization problems. I’m using the UART interface so I’m not plagued by those it appears so far.


#6

Has anyone heard back about this issue? The first boot works for me on every pi at the shop, but lights fail after rebooting the pi.


#7

n7, the ‘official’ word appears to be that the R410-based design does not have these issues, though I have heard nothing back from Hologram about being able to exchange my R404 for one as of this moment. I may just have to bite the bullet and buy one outright, or find another solution altogether.

tve, I looked into the UART interface but it appears that I would have to physically modify the unit in order to access such a mode. It is promising to hear that the UART does not appear to be affected by the same problems the USB interface is, though considering the USB interface is the only ‘officially’ supported way to interact with the modem, it does make sense that Hologram’s solution would be to abandon the R404 design in favor of the R410.


#8

Thanks for the reply. Hopefully they will let us swap up. We are working on an unattended solution so reboot is pretty important. Keep me posted if you hear anything back from them. I’ll do the same.


#9

Hey @nomakewan,

Could you please reach out to us directly by sending an email out to success@hologram.io. I want to make sure this gets taken care of.

Best,
Maiky


#10

For everyone who has participated in this thread or anyone who might be reading it now, the R404 was an engineering sample released to provide earlier access for development with an LTE band modem. The modem used was the u-blox Sara R404-ES engineering sample module.

Our aim here was to give technical users a preview of what the now in production R410 Nova would be like. The R410 Nova uses the u-blox Sara R410 modem which is production ready and is more robust thus providing a better development experience.

For anyone still having issues with their R404 after having followed the instructions here, please email us directly at success@hologram.io so we can help you out.

Best,
Maiky


#11

Your “here” word doesn’t link anywhere…


#12

Sorry I hit reply before I had this answer all worked out. Should be good to go now.


#13

I would like to state for the record that I was able to successfully trade up to the R410M thanks to @Maiky and his awesome help. The new modem does not have the power-up issues over USB that the R404 had and has survived several reboots without any issues whatsoever. I did have a minor issue with it that required running an AT command to fix (the R410M wouldn’t connect out of the box, I had to run AT+UMNOPROF=3 to get the modem to use Verizon’s network), but other than that everything went smoothly.

I know the original poster was looking for UART details, and I apologize that I cannot provide those details. I can say, however, that the problems reported with the R404 do not exist with the R410M. Cheers!


#14

Hey @nomakewan,

Thanks for the kind words! We’re always happy to help in any way we can.

With regards tot he R410, we are constantly working to smooth out the kinks. Since the modem is new, the network is new and the device is new there are a lot of things we are uncovering through testing and user feedback.

I also wanted to point out that we released a new update to the SDK that should increase stability with the R410 Nova.

Best,
Maiky