Raspberry Pi Hologram Import error


#1

Hello,
I am using the Nova with hologram sim card. I have been able to send messages through the command line to the console of hologram dashboard. Now, I am trying to use python program to send the data but I am getting…

from Hologram.CustomCloud import CustomCloud
ImportError: No module named ‘Hologram’

I have installed and updated using

curl -L hologram.io/python-install | bash

Any advice? Much apprectiated!


#2

Any advice?


#3

pi@raspberrypi:~ $ sudo curl -L hologram.io/python-update | bash
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 178 100 178 0 0 108 0 0:00:01 0:00:01 --:–:-- 108
0 0 0 0 0 0 0 0 --:–:-- 0:00:02 --:–:-- 0
100 374 100 374 0 0 90 0 0:00:04 0:00:04 --:–:-- 1438
Reading package lists… Done
Building dependency tree
Reading state information… Done
libpython2.7-dev is already the newest version (2.7.13-2+deb9u3).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Requirement already up-to-date: hologram-python in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: python-sdk-auth==0.2.1 in /usr/local/lib/python2.7/dist-packages (from hologram-python)
Requirement already up-to-date: pytest==3.0.5 in /usr/local/lib/python2.7/dist-packages (from hologram-python)
Requirement already up-to-date: psutil==5.3.1 in /usr/local/lib/python2.7/dist-packages (from hologram-python)
Requirement already up-to-date: pyudev==0.21.0 in /usr/local/lib/python2.7/dist-packages (from hologram-python)
Requirement already up-to-date: mock==2.0.0 in /usr/local/lib/python2.7/dist-packages (from hologram-python)
Requirement already up-to-date: pyusb==1.0.0 in /usr/local/lib/python2.7/dist-packages (from hologram-python)
Requirement already up-to-date: python-pppd==1.0.3 in /usr/local/lib/python2.7/dist-packages (from hologram-python)
Requirement already up-to-date: pyroute2==0.4.21 in /usr/local/lib/python2.7/dist-packages (from hologram-python)
Requirement already up-to-date: enum34==1.1.6 in /usr/lib/python2.7/dist-packages (from hologram-python)
Requirement already up-to-date: hjson==2.0.2 in /usr/local/lib/python2.7/dist-packages (from hologram-python)
Requirement already up-to-date: python-wifi==0.6.1 in /usr/local/lib/python2.7/dist-packages (from hologram-python)
Requirement already up-to-date: pyserial==3.3 in /usr/local/lib/python2.7/dist-packages (from hologram-python)
Requirement already up-to-date: requests==2.18.3 in /usr/local/lib/python2.7/dist-packages (from hologram-python)
Requirement already up-to-date: pycrypto==2.6.1 in /usr/lib/python2.7/dist-packages (from python-sdk-auth==0.2.1->hologram-python)
Requirement already up-to-date: py>=1.4.29 in /usr/local/lib/python2.7/dist-packages (from pytest==3.0.5->hologram-python)
Requirement already up-to-date: six in /usr/local/lib/python2.7/dist-packages (from pyudev==0.21.0->hologram-python)
Requirement already up-to-date: funcsigs>=1; python_version < “3.3” in /usr/local/lib/python2.7/dist-packages (from mock==2.0.0->hologram-python)
Requirement already up-to-date: pbr>=0.11 in /usr/local/lib/python2.7/dist-packages (from mock==2.0.0->hologram-python)
Requirement already up-to-date: idna<2.6,>=2.5 in /usr/local/lib/python2.7/dist-packages (from requests==2.18.3->hologram-python)
Requirement already up-to-date: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python2.7/dist-packages (from requests==2.18.3->hologram-python)
Requirement already up-to-date: certifi>=2017.4.17 in /usr/local/lib/python2.7/dist-packages (from requests==2.18.3->hologram-python)
Requirement already up-to-date: urllib3<1.23,>=1.21.1 in /usr/local/lib/python2.7/dist-packages (from requests==2.18.3->hologram-python)


#4

Hey @grp320,

It looks like everything installed correctly. I’d double check that you are using Python 2, that you can find the Hologram files and that all your libraries are installed somewhere where your path can find them.

Best,
Maiky