RPi 4 Boot Hangs Nova + Witty Pi

Hi all,

I am trying to use the Nova modem with a Raspberry Pi 4B and Witty Pi power management board. I can get it to boot with the Nova plugged in and power going direct to RPi (first video), Nova unplugged and power into Witty Pi (second video), but the boot hangs when I have the Nova plugged in and power via Witty Pi (third video). If I unplug the Nova while the Pi is hungup during boot, then plug it back in a few seconds later everything comes up fine.

-Tested on 2 different Raspberry Pi 4B’s (all three videos use the same RPi)
-Hologram Nova plugged into USB 2.0 port
-Witty Pi 3 Mini
-5V 3A USB charger (only difference between tests is USB-C and USB mini cables)
-I’ve tested with an old 5V 700mA charger and have the exact same results
-Running Raspian (Legacy) with full-upgrade performed
-Sending messages and connecting data via Hologram work fine once booted. Receiving cloud messages hasn’t worked for me so far (dashboard says it can’t connect to the device)

Has anybody seen this? My hunch is something power-related with the supply from the Witty Pi as the Nova LED never comes on when booting under the 3rd conditions. The green LED does not seem to flash in any of the standard boot error sequences either. The Witty Pi will attempt to sync time with an internet source if internet is available (when booted using the Witty Pi). Is it possible the presence of the Nova modem confuses this script into thinking there is internet available and that’s where it hangs?

Videos to show status LEDs under each case: Nova plugged in + power to Pi - YouTube

Since posting I’ve tried a few more things:
-Disabling startup script for Witty Pi
-Updating U410 firmware (already up to date)

I still cannot get the Nova power LED to turn on when powering via Witty Pi

Very possible it’s not getting enough power. Using a separate USB power adapter with an unattached cable can be dicey because it’s not always clear if the cable is a high enough gauge to not prevent a voltage drop across it that would cause a brownout of the pi. We usually recommend something like this: https://www.amazon.com/CanaKit-Raspberry-Supply-Adapter-Listed/dp/B00MARDJZ4/ref=sr_1_4?keywords=raspberry+pi+power+adapter&qid=1648862669&s=electronics&sprefix=raspberry+pi+power+adapter%2Celectronics%2C314&sr=1-4

That being said, I don’t have any experience with the Witty Pi so I don’t know if that could be causing some issues with the power management. One thing you can try is booting it up with HDMI plugged in and see if you get the rainbow square which indicates an undervolt condition.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.