SARA-R410M Korea Direct UDP/SMS Blackhole/drop?


#1

I have my Sodaq / Ublox SARA-R410M connected using SK Telecom here in Korea.

Sending UDP and getting the immediate response is no problem.

Sending direct UDP packets to the Ublox however seems to get blackholed.

I enable URC
AT+CNMI=1,1

I open a socket
AT+USOCR=17

Then listen on a particular port 2345
AT+USOLI=0,2345

Everything returns OK

Then I use “Send to Device / UDP / Port 2345” from the hologram dashboard and get “Socket error: timed out”. Is it safe to assume that my carrier is blocking incoming UDP?

Then I tried to SMS using the Dashboard but got nothing on the Ublox

Then I bought a phone number (US) for the SIM, then SMSed it using a phone, but got nothing on the Ublox either.

I also tried to use SpaceBridge, set up keys, tunnel then used nc to send data through the ssh tunnel, but of course, nothing appeared on the Ublox.

Anyways, since we know UDP is working (send with an immediate receive), any idea why direct UDP (without first sending) and SMS seems to get blackholed?


#2

Hello @awef,

Love the profile pic.

With regards to your issues, I just wanted to check a few things. Have you been able to test TCP? Also for Spacebridge was your device in an active connection?

The SMS issues seem a bit reasonable given that you bought a US phone number and are using this in Korea, it could be that that is causing some issues with delivery on the circuit switched network.

When you have a chance could you run this modem diagnostic and send it to success@hologram.io so we can take a closer look at this.

Best,
Maiky