Sending Data to device from the Dashboard

I am having difficulty sending a message from the Dashboard to a device.
It is a new device as of today. The SIM has been provisioned and it is successfully connecting. When the device connects it sends a data packet out to Hologram. As expected, it gets rejected with a [3,0] because the Device Key is not set yet.
I try to send a message through the dashboard using Cloud data TCP to the device. The message contains configuration data for the device. The Device Key is one of those items. Once the device receives that packet it stores it in Flash.
The problem is the packet never makes it to the device. The port is opened, dashboard said it sent successfully. The device never gets it.
I know the connection is good because the device sends the data packet at the beginning and gets a response back from Hologram ([3,0]). So the connection is active and passing data.

What else could I check?

Edit: I should note, that it has worked with other devices in the past.

Can you give it another try? We just added a new IP subnet and it wasn’t fully spun up until the last 15 minutes or so.

That worked. Thanks.