Sending SMS AT commands in Serial pass through sample code


#1

I’m running konekt_user_module_serial_gateway.ino in ARDUINO (Board version 0.9.2) and it works on some AT Commands but gives unexpected responses on the following:

  • AT+CGACT=1 spits out ERROR message on first attempt and will be OK on the succeeding attempts… though the first try actually set it to 1,1.

  • AT+CMGS=“0123456789” spits out ERROR

I’m trying to send an SMS message directly to UBLOX but can’t continue because of the AT+CMGS error.

Here are the Arduino Serial Monitor logs before executing AT+CMGS:
+CPIN: READY
+COPS: 0,0,“Globe Telecom-PH”,2
+CREG: 2,1,“7618”,“C8B7035”,6
+UREG: 0,6
+CGACT: 1,1
+CFUN: 1,0
+CGDCONT: 1,“IP”,“HTTP.GLOBE.COM.PH”,“100.84.134.23”,0,0


#2

I think my reply here Issue on version 0.10.1 in Arduino 1.6.11 covered this. We’re hoping to get more information about our new API for this out soon.


#3

Thanks Reuben.

I tried to execute other UBLOX AT COMMANDS and it seems that eventhough you see ERROR in the Arduino’s Serial Monitor, and not seeing the supposed “returned values” from UBLOX, the commands are nevertheless executed properly. I encourage others to just continue with the AT Command execution and see the end result in the Mobile/Server side. This is while waiting for the new API as promised by Hologram.

For those trying to change the APN setting via AT Commands, try the codes shown below. You will encouter ERROR when executing AT+UPSDA=0,3… but as I said, it is actually executed at UBLOX. I saved the APN setting in the Non Volatile Memory of UBLOX to make it permanent and never set it again during normal operation.


Ways to send AT commands to Ublox!
#4

In passthrough mode all responses are generated by the ublox. So if ERROR is returned, either the command was not correct or other pre-requisite commands have not been set. The AT+CMGS command depends on the state of AT+CMGF for example.


#5

Thanks Erik. I’ll check the pre-requisite commands if I missed something…
But in my case, I followed the series of commands that is shown in the screenshot and the UBLOX returned ERROR when executing AT+UPSDA=0,3. I hope someone try this to see if I’m the only one having it.

Also, I tried to execute the verbose log option (AT+CMEE=2) to see details of error, but the output in Arduino’s Serial Monitor is still just ERROR. Does the download parser in the SerialCloud.read() module has something to do about this?