SIM card takes long time to connect (and only to GSM)



I’m currently resided in China. I just got the SIM card today and tested with SIM7000C and Quectel BC28 (and it only succeeded with SIM7000C). I noticed it takes about 1 hour to get connected (The “AT+COPS?” command returns the operator as shown below). And, it can only connected to GSM on China Unicom. (When I set to LTE only, it won’t connect)

I tested the “AT+COPS=?” command, it returns as follows:
+COPS: (1,“460 00”,“460 00”,“46000”,0),(1,“460 01”,“460 01”,“46001”,0),(1,“460 00”,“460 00”,“46000”,9),(1,“460 11”,“460 11”,“46011”,9),(0,1,2,3,4),(0,1,2)


Anyone has the same issue with the long connection time and GSM only? And any way to solve it?

Thanks and regards,


Hey Skyin,

Please look at this thread: SIM/Device re-registration duration


Hi Maiky,

I don’t think it is related to the network registration time. I tried SIM7000E in Singapore also (with a Singtel NB-IoT SIM card). The slowest registration time I have seen is less than 10 mins. An hour is definitely too long for that. And, I can’t connect to the LTE network.

I tried the Hologram SIM card on a botletics shield (with SIM7000G) here in China also, it has the same problem… It can find the LTE operators with the “AT+COPS=?” command, but unable to connect.


Hey Skyin,

In that case I am not sure. An hour is definitely way longer than anything I have seen before, but its curious that it connects after that. Normally in these situations I like to consult the devices documentation. An easy sanity check would be inserting your SIM into an unlocked phone just to make sure everything is set up properly.

Once you connect for the first time does it still take a long time to connect?


Hi Maiky,

Thanks for the suggestion. I tried today and the SIM was able to connect to LTE on a phone. (But I can’t use the data to browse sites or send SMS, which I’m not sure if it is suppose to be like that?)

As for the SIM7000C module, it still takes a long time to connect after the first time connection, and only on GSM network. The weird part is that with all the settings the same, when using a China Telecom NB-IoT card, the module has no trouble to connect to LTE…


Hey Skyin,

Can you send your SIMs number to so we can take a look at it. Not sure what’s causing the issues.

As far as the modem goes, I’d also test connection times when you isolate certain radio access technologies to see if one of those is the culprit. Our SIM cards need to roam and roaming agreements for Cat-M1 and NB-IoT are still in their infancy so that might be an area of friction.


Hey Skyin,

We didn’t find anything off with your SIM card. Have you tried isolating the radio access technologies?



Hi Maiky,

I just realized it’s because Hologram is able to connect to traditional LTE in China only. That’s why my phone could show the network. China have no LTE Cat-M1 but only LTE Cat-NB1. But Hologram not supporting Cat-NB1 yet in China. That’s why the SIM7000 module cannot connect to LTE Cat-NB1 network.

I’m currently changing to a local NB-IoT SIM card. Anyway, great thanks for the support on helping me to find the problem!

Best regards,


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.