SIM7080G unable to access the internet.


I’m having trouble in getting my device to connect to the internet. My setup is a Raspberry Pi 3 Model B (using the latest RPi OS with desktop as of May 2023) that has a Cat-M/NB-IoT HAT using SIM7080G attached to it. Here’s a website of the product in question, and it’s wiki page where you can find the AT commands manual pdf files.

Unfortunately as a new user here, I’m unable to upload the AT commands manual pdf. and post the more than two links. You’ll be able to find the AT Commands manual near the bottom of the page from the link above, or in my own reply to this thread.

I have had my HyperSIM activated and after configuring the APN to hologram, I’m only able to reach hologram’s global network, but not the internet. That is what you may call a ‘session without data’ or ‘zero-byte session’.

I’ve tried to troubleshoot my device through the use of AT commands, that includes trying out the Modem/SIM diagnostic test both manually and automatically. But to be honest I’m just a beginner in this field and my lack of familiarity of these is giving me a great challenge to deal with. (just getting started since last week)

I’ve ran the modem diagnostics python script, to which some of its errors are quickly fixed due to some difference in the syntax for the AT commands. The rest of the diagnostics from the python script worked well.
I can confirm that the APN is correct. Running the command AT+CGNAPN returns me
+CGNAPN: 1, “hologram”

Then, I’ve tried to run some commands from Section 7 (pages 143 to 145) of the AT Commands manual on IP Application.
Tried running AT+CNACT=0,1 by referring to another website

and it returned

However, there wasn’t any changes to the status of my internet access, let alone pinging in ipv4.
Also, they don’t save the configurations to the device after rebooting. which makes any changes redundant.

I may also suspect that my Raspberry Pi and/or the HAT itself may be the cause of the problem.
The SIM is working as expected, being able to connect to Hologram’s global network and opening sessions. But its just that there’s no data being sent/received.
When I ran AT+CNACT? or even AT+CGPADDR, there’s this address shown.

However in my Raspberry Pi terminal, running hostname -I, and also ifconfig (after disconnecting from my home network), it is showing a home-esque network ip address at at interface eth1 Removing the HAT removes eth1 and there are no addresses shown.

The HAT is somehow tied to interface eth1. Tried setting it to use dhcp and it gives the address. Configuring it to the PDP address of doesn’t help.

It did briefly access the internet, albeit with a single 960b session for one second and that’s it. Similar attempts to do the same steps (AT commands and configuring the interface) yielded nothing.

I’d like to request any assistance to help me resolve my issue.
I’m keen to understand what went wrong and/or what crucial stuff that I’m missing and also find out what’s preventing my access to the internet after reaching Hologram’s global network.

Kind regards,

Attaching the link to the AT Commands manual for SIM7080G pdf.

Also, regarding the PDP address of, the commands are mostly referred to Section 6 (page 140+) of the manual. Error codes are at the bottom of the manual (pages 250+)

Here’s another screenshot of what I’ve tried. Pinging doesn’t work for me.

Fellow cell board tinkerer here (SIM7000 and SIM7600), after reading your post I’ve been tinkering with my 7000 and comparing HTTP AT commands between the 7000 and the 7080.

Anyways, concerning the ping command in your screenshot, this might be a longshot, but it’s possible your ping command is missing some terms. Check out the ping command example on page 5 of that “PING Application Note” pdf near the bottom of the Waveshare webpage, and note the extra 3 terms. Then look at that same command in the AT manual. Note those 3 extra terms are not in brackets, ie, no [ ].

If I understand the AT manual format correctly, anything in [ ] is optional. In other words, I think you need those 3 additional terms like in the ping example on page 5 of that PING application note.

Again, might be a longshot, and I might be wrong, but worth a try maybe?

Yep, me again, just compared the AT ping command between the 7000 and the 7080, the 7000 “ping” from its AT manual has [ ] around the last 3 terms:


and yep, I don’t need any of those 3 terms to ping on my 7000.

But the 7080 “ping” from its AT manual looks like:


No [ ] like the 7000 version, so I think you need all 4 terms.