SIM7080G unable to access the internet.


I’m having trouble in getting my device to connect to the internet. My setup is a Raspberry Pi 3 Model B (using the latest RPi OS with desktop as of May 2023) that has a Cat-M/NB-IoT HAT using SIM7080G attached to it. Here’s a website of the product in question, and it’s wiki page where you can find the AT commands manual pdf files.

Unfortunately as a new user here, I’m unable to upload the AT commands manual pdf. and post the more than two links. You’ll be able to find the AT Commands manual near the bottom of the page from the link above, or in my own reply to this thread.

I have had my HyperSIM activated and after configuring the APN to hologram, I’m only able to reach hologram’s global network, but not the internet. That is what you may call a ‘session without data’ or ‘zero-byte session’.

I’ve tried to troubleshoot my device through the use of AT commands, that includes trying out the Modem/SIM diagnostic test both manually and automatically. But to be honest I’m just a beginner in this field and my lack of familiarity of these is giving me a great challenge to deal with. (just getting started since last week)

I’ve ran the modem diagnostics python script, to which some of its errors are quickly fixed due to some difference in the syntax for the AT commands. The rest of the diagnostics from the python script worked well.
I can confirm that the APN is correct. Running the command AT+CGNAPN returns me
+CGNAPN: 1, “hologram”

Then, I’ve tried to run some commands from Section 7 (pages 143 to 145) of the AT Commands manual on IP Application.
Tried running AT+CNACT=0,1 by referring to another website

and it returned

However, there wasn’t any changes to the status of my internet access, let alone pinging in ipv4.
Also, they don’t save the configurations to the device after rebooting. which makes any changes redundant.

I may also suspect that my Raspberry Pi and/or the HAT itself may be the cause of the problem.
The SIM is working as expected, being able to connect to Hologram’s global network and opening sessions. But its just that there’s no data being sent/received.
When I ran AT+CNACT? or even AT+CGPADDR, there’s this address shown.

However in my Raspberry Pi terminal, running hostname -I, and also ifconfig (after disconnecting from my home network), it is showing a home-esque network ip address at at interface eth1 Removing the HAT removes eth1 and there are no addresses shown.

The HAT is somehow tied to interface eth1. Tried setting it to use dhcp and it gives the address. Configuring it to the PDP address of doesn’t help.

It did briefly access the internet, albeit with a single 960b session for one second and that’s it. Similar attempts to do the same steps (AT commands and configuring the interface) yielded nothing.

I’d like to request any assistance to help me resolve my issue.
I’m keen to understand what went wrong and/or what crucial stuff that I’m missing and also find out what’s preventing my access to the internet after reaching Hologram’s global network.

Kind regards,

Attaching the link to the AT Commands manual for SIM7080G pdf.

Also, regarding the PDP address of, the commands are mostly referred to Section 6 (page 140+) of the manual. Error codes are at the bottom of the manual (pages 250+)

Here’s another screenshot of what I’ve tried. Pinging doesn’t work for me.

Fellow cell board tinkerer here (SIM7000 and SIM7600), after reading your post I’ve been tinkering with my 7000 and comparing HTTP AT commands between the 7000 and the 7080.

Anyways, concerning the ping command in your screenshot, this might be a longshot, but it’s possible your ping command is missing some terms. Check out the ping command example on page 5 of that “PING Application Note” pdf near the bottom of the Waveshare webpage, and note the extra 3 terms. Then look at that same command in the AT manual. Note those 3 extra terms are not in brackets, ie, no [ ].

If I understand the AT manual format correctly, anything in [ ] is optional. In other words, I think you need those 3 additional terms like in the ping example on page 5 of that PING application note.

Again, might be a longshot, and I might be wrong, but worth a try maybe?

Yep, me again, just compared the AT ping command between the 7000 and the 7080, the 7000 “ping” from its AT manual has [ ] around the last 3 terms:


and yep, I don’t need any of those 3 terms to ping on my 7000.

But the 7080 “ping” from its AT manual looks like:


No [ ] like the 7000 version, so I think you need all 4 terms.

Hello atok,

Thank you very much for your help, the ipv4 ping worked.


Even if pinging works, I have to test out the other functions of the device (e.g. https, tcp/udp) to confirm that everything is working in order.
However I’m still a bit confused on why am I not able to access a website (e.g. hologram) on my internet browser, and I’m still searching for answers on this matter.

Kind regards,

Ok, cool, at least you’re getting to the internet, now about the HTTP GET.

Sorry if you saw this already, but did you look at the HTTP GET example on page 12 of that Simcom 7070/7080/7090 HTTP(S) Application Note pdf that was in your Twilio link?

If you want a simpler URL test site than the one in the example this is one I often use:

It’s just a two-line, text only website.

Hello @atok

My apologies for the late reply. Was performing some other troubleshooting on my Raspberry Pi (fiddling with some other modules connected via GPIO).

No worries, I haven’t looked at it thoroughly (but did a brief look at the time of writing this). Though I’ll be working on this once the troubleshooting is done.

Strange thing is that I’ve tested out that test site from a web browser, and the browser still says there’s no internet while I could still perform a ping.
I wouldn’t want to jump to conclusions without any confirmations, but I may guess that the internet connections from the SIM7080G comms HAT is only limited to the AT commands.
That is, I may check out the guide and commands manual to see if I could access that website.

Kind regards,

Hi yi95,

Am curious about your Pi/7080 combo project … are you only sending sensor data, or aiming for a portable browser, or ?? Just wondering about the overall function.

It’s too bad the HTTP AT commands for the 7080 are so different from the 7000 and 7600 otherwise we could both be testing things. Anyways, I’ve been curious about the 7080 for awhile, plus the fact I could get a 7080 breakout board for just $14 on AliExpress, so I ordered two to try out! They are in the US now, so maybe next week I’ll also be able to do some 7080 testing.

Ok, hope all’s well,

Hi yi95,

I got my 7080’s today and tinkered with them using PuTTY and a USB cable until I got HTTP GET working. I don’t know why just yet, but I can only get it working for the website “” so far.

Although I didn’t do extensive testing, I found the following settings worked for both internet and sms (I wanted sms working too as I also have T-Mobile “hobby” sims as well as Hologram sims):


Then I entered the following:


To check the above enter:


You should see:


Open a connection:


Connect to the website:


Get the http:


Hopefully you get the following back:

+SHREQ: “GET”,200,1256

Then enter (note the 1256 below matches the 1256 in the SHREQ response above):


Then you’ll set the website HTTP text fly by.

To disconnect from the website:


To close the connection:


Tried the above with both a Hologram sim and a T-Mobile sim, both worked. Again, not sure why I can’t get it working for google or the Adafruit test site yet. I’ll likely tinker some more over the week, will update the post if I learn something.

Also interesting that I didn’t need to enter the APN for either sim, somehow CGNAPN took care of itself, though you can enter AT+CGNAPN to double-check after powering up (note there is no ? at the end of that command).

Ok, hope all’s well.

Yup, me again, figured out how to get it working for the Adafruit wifi test site, below are the relevant two lines:



And nope, still can’t figure out how to get it to work for google, maybe I need to use the https example, ug… Ok, maybe I’ll get bored in a day or so and give that a try.


Aargh, figured it out, or at least I get back a “200” HTTP status code with the SHREQ response, which is good.

Anyways, I happened to notice in the SIM7080 HTTP Application Notes pdf on their Yahoo example (page 7) they had a trailing “/” after, that was it.

So, like above, here’s the two relevant lines:



and the SHREQ response was:

+SHREQ: “GET”,200,17214

So, there you go, why some sites need the trailing “/” and some don’t I wish I knew.

Can I piggy back a 7080 question here? I’m finding at+CMGL for listing SMS msgs does not work well when sleeping the 7080G in eDRX mode. The manual says " If
TE is inactive (e.g. DTR signal is OFF), message receiving should be done
as specified in GSM 03.38. " but I can’t translate that into what I should differently. Thoughts anybody?