SIM800 + Hologram


#1

I’m using the latest build of the hologram for SIMCOM module libraries. (debug - I know the module is working properly used it for other things)

library: https://github.com/hologram-io/hologram-SIM800 by @benstr

I’m using the developer SIM just got it in the mail - in Zone 2 (though I am operating out of the USA) mode.

I can’t get a successful connection though, I am currently failing at the CIFSR step. Any help would be appreciated. This is the response I get when running the Blink example:

DEBUG: Verbose monitoring and modem serial access enabled
DEBUG: Write Modem Serial = AT

DEBUG: Modem Serial Buffer = AT
DEBUG: Modem Serial Buffer = OK
DEBUG: Write Modem Serial = AT+IPR=9600

DEBUG: Modem Serial Buffer = AT+IPR=9600
DEBUG: Modem Serial Buffer = OK
DEBUG: Write Modem Serial = AT+CPIN?

DEBUG: Modem Serial Buffer = AT+CPIN?
DEBUG: Modem Serial Buffer = +CPIN: READY
DEBUG: Modem Serial Buffer = OK
DEBUG: Write Modem Serial = AT+CSQ

DEBUG: Modem Serial Buffer = AT+CSQ
DEBUG: Modem Serial Buffer = +CSQ: 5,0
DEBUG: Write Modem Serial = AT+CMGF=1

DEBUG: Modem Serial Buffer = OK
DEBUG: Write Modem Serial = AT+CIPSHUT

DEBUG: Modem Serial Buffer = AT+CMGF=1
DEBUG: Modem Serial Buffer = OK
DEBUG: Modem Serial Buffer = AT+CIPSHUT

DEBUG: Modem Serial Buffer = SHUT OK
DEBUG: Write Modem Serial = AT+CSQ

DEBUG: Modem Serial Buffer = AT+CSQ
DEBUG: Modem Serial Buffer = +CSQ: 8,0
DEBUG: Write Modem Serial = AT+CGATT?

DEBUG: Modem Serial Buffer = OK
DEBUG: Write Modem Serial = AT+CIPMUX=1

DEBUG: Modem Serial Buffer = AT+CGATT?
DEBUG: Modem Serial Buffer = +CGATT: 1
DEBUG: Modem Serial Buffer = OK
DEBUG: Write Modem Serial = AT+CSTT=“hologram”

DEBUG: Modem Serial Buffer = AT+CIPMUX=1
DEBUG: Modem Serial Buffer = OK
DEBUG: Write Modem Serial = AT+CIICR

DEBUG: Modem Serial Buffer = AT+CSTT="hologram"
DEBUG: Modem Serial Buffer = OK
DEBUG: Write Modem Serial = AT+CIPSERVER=1,8888

DEBUG: Modem Serial Buffer = AT+CIICR

DEBUG: Modem Serial Buffer = OK
ERROR: Timeout when calling AT+CIPSERVER=1,8888
| elapsed ms = 0
ERROR: Server start timed out
Cellular connection failed
Setup complete


#2

I have an update releasing in a day or two that fixes this. These modules are really slow and need more time before requesting a local IP.

Since you have debug() running, you can send commands to the module through the serial.

First, let’s check if you have any signal. Send AT+CSQ, you want it to return 2 thru 31 anything more or less means you do not have coverage, sorry.

If you have coverage, next send AT+CIICR, if that works run AT+CIFSR. If it responds with an IP address then you should be good to continue.

I’ll post back here once the updated library is available.


#3

Alright sounds good, I’ll make an update once I’ve completed some stability testing myself, I found that setting serial to 9600 and the device to 4800 seems to be working fine. I also added some delays just to keep things safe.