[SOLVED] Any success sending SMS to U-Blox SARA-R410M-02B or any SARA-R4 module?


Hi All,

I am not able to receive any SMS on my U-Blox SARA-R410M-02B module. I verified I have an active SIM and can register on the network (Verizion LTE Cat-M1) as well as make HTTP requests.

I have sent multiple messages to the device using the Hologram dashboard and it indicates that the message send succeeded but I get no URC or messages showing on the device.

When I run the AT+CPMS command I always get an error. I think this may be part of the issue but no matter what I do, I am not able to get an “OK” from the device:

+CPMS: "ME",0,23,"SM",0,10,

I am betting this is a U-Blox config issue on my end but I wanted to reach out on this forum (which is more active than U-Blox) to see if anyone has had success with this.




Solved my own issue:

I found out it was a configuration issue with the AT+CPMS command, I needed to provide 3 fields, not 2:

+CPMS: 0,23,0,23,0,23


And after a few seconds, SMS messages showed up:

+CPMS: "ME",2,23,"ME",2,23,"ME",2,23


Note I took this from Hologram’s Python SDK (line 34)


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.