Spacebridge Connection hangs

For context, I’m currently trying to use Spacebridge as an alternative connection to SSH into my devices in case the network goes down. After getting the device connected and activated on the dashboard, I’ve:

  1. Generated a public key on my local device and uploaded it via API
  2. Enabled tunneling on the dashboard
  3. Run “hologram spacebridge” on the remote device, which responds saying it’s listening on port 4010
  4. Run “ssh -p 999 -L 5000:link<LINK_ID>:22 -N -i spacebridge.key htunnel@tunnel.hologram.io

Unfortunately, the connection just hangs afterwards. I also tried running “ssh -p 999 -L 5000:link<LINK_ID>:4010 -N -i spacebridge.key htunnel@tunnel.hologram.io”, but that hung as well. I’ve verified that my device can send messages to the dashboard. Let me know if anyone can provide any insight here.

Thanks,

Nathan

Have you tried using the spacebridge client?

We just updated the server to python 3 so any spacebridge issues are of interest to us, though currently our tunnel monitoring is not showing any issues.