Spacebridge CPU usage

Hi everyone - I recently setup a machine with an USB modem and spacebridge. The system is a home sensor network and adding the cell link for backup connectivity could not have been easier with the python cli tool - Thanks!
I am posting to ask if anyone has had issues with the spacebridge client using a ton of cpu. I am not running a pi - so maybe that’s the issue, but I am running Ubuntu 14. It seems like when the spacebridge process starts it begins using most of my cpu cycles. When I kill the process the machine is still connectable via spacebridge. So I am thinking maybe there is some sort of exit code which is not being returned and maybe the code is stuck in a retry loop? Wondering if anyone has heard of this sort of thing happening. The computer is an intel NUC - Intel® Celeron® CPU N3050 @ 1.60GHz running 14.04.5 LTS (GNU/Linux 4.4.0-92-generic x86_64).


Hmm we haven’t noticed that before but we’ll look into it. You’re saying that the port is still being forwarded after the process ends? That shouldn’t happen if the process is actually gone.

Hi Reuben!
So I think I am talking about another process. I meant to include this image:

In trying to test this more I tried
ps ax | grep python and got:

For some reason this was not connectable. I killed those two processes and re-ran sudo python spacebridge and had the same results as the first screenshot, but now connectable. I think the not connectable thing is unrelated - maybe related to a reboot…

I running ‘python hologram spacebridge’ supposed to be blocking?

Oh, I see. You’re seeing an issue in the SDK command. We’ll take a look at that and try to get a fix in the next release


Hey guys - I’m still seeing this problem - same machine, now Ubuntu 16. What is strange is the CPU is like 98% but everything on the machine seems to be running fine. It’s almost like the usage is not reporting right for the space bridge script.

Is there another way I can run the script as a daemon reliability? Currently I check if port 4010 is in use every so often. I run hologram spacebridge & disown if it is not.
Sorry if this is not related to the SDK, but I figure I would post and see if I am doing something wrong since I have had this issue with 2 different OS installations.