Spacebridge Error and windows 10


I’m running the latest Windows 10, 1709. Spacebridge.exe crashes for me right on startup.

Error decompressing msvcp90,DLL

Any ideas?


Hmm, I’m on 1703 and it works fine. We’ll investigate this further. Do you have Visual Studio or the Windows SDK installed? I wonder if it would conflicting with libraries on your system.


I don’t have anything yet on this laptop that wasnt put there by microsoft.


What kind of laptop is it? Is it running a non-x86 processor like Atom? We’ve tried on a few Windows 10 machines and haven’t seen this issue so far.


no. Its an i7, HP Spectre x360, Kaby Lake version.


This is the version you’re getting off our download page?




Hey, we’re a little stumped on this. We have a guy here with the same laptop as you and it works. We’ve also tried on a couple other Win10 systems that are close to being fresh out of the box and they’ve all worked.

My suggestion would be to download again in case something got corrupted the first time and if that doesn’t work you can get the raw python code from our github and try running that.
Or, you don’t need to use the spacebridge client at all and can just use an ssh client. We have instructions here:
Take a look at the section that says “Tunneling Without the Spacebridge Client”


Strange thing. It works now. No idea what makes it different than the other day. Thanks for your help!


Heh weird. Well glad it’s working now.