Spacebridge tunneling not working?


So following the tutorial on the hologram website, and tried the gui binary that you can download. Then I tried ssh localhost -p 5000 and ssh pi@localhost -p 5000 to no success (just the new blank line return). So then I tried using the second option of doing it CLI. After successfully uploading the same spacebridge keys, running: ssh -p 999 -L 5000:link(mylink#):22 -N -i ~/.hologram/spacebridge.key on my laptop gives the blank return line (which I imagine is fine), and then running the same two ssh commands as before returns the same blank new line. I definitely have tunneling enabled in the dashboard, and I am not sure what the problem is now. Any help would be greatly appreciated so I can get ssh running!



Hi, can you give some information about how the Pi is connected to the cellular network? Are you using a Nova?
It sounds like you might be running into a common routing issue where the SSH connection is tried to route back over wifi instead of cellular and it doesn’t work.
Paste the output of the route command


Sorry, yes I am using a Nova. Here is the output of the route command:
pi@pizerow:~ $ route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface default FIOS_Quantum_Ga UG 302 0 0 wlan0 U 302 0 0 wlan0
Here is a screen-shot for better formatting


Ok yeah, looks like the cellular connection isn’t even up there. Try running hologram modem connect and then see if spacebridge works.


Works! Thanks so much!


Nice, happy to help

closed #8

This topic was automatically closed after 30 days. New replies are no longer allowed.