Spacebridge with 3rd Party USB Modem

Hi all,

I’ve been a Hologram fan for years and was delighted to see the Spacebridge feature. I tried it out, but so far have had no success connecting to my device.

My setup:

Remote device:

  • Raspberry Pi 4B
  • Raspbian Bookworm 64bit Lite
  • SSH enabled, and confirmed I can SSH locally via Putty
  • Quectel EC25-A Modem with PCIe to USB adapter
  • Using ModemManager
  • I can run ping -I wwan0 successfully, so the modem is working and it’s also showing as Connected|LTE on the Hologram Dashboard

Local Device:

  • Desktop PC with Win10 and Spacebridge client

What I’ve tried:

  • Created tunnel using Spacebridge client, passing in my API key, selecting the correct SIM and entering 5000 as local port and 22 as remote port
  • Opening Putty with as IP and 5000 as port

I get:

*PuTTY Fatal Error: Remote side has unexpectedly closed the connection.

Debug info:

ip route

default via dev wlan0 proto dhcp src metric 600
default via dev wwan0 proto static metric 700 dev wwan0 proto kernel scope link src metric 700 dev wlan0 proto kernel scope link src metric 600

ip a

5: wwan0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
    inet brd scope global noprefixroute wwan0
       valid_lft forever preferred_lft forever

ping -I wwan0 -c 5

PING ( from wwan0: 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=52 time=469 ms
64 bytes from ( icmp_seq=2 ttl=52 time=429 ms
64 bytes from ( icmp_seq=3 ttl=52 time=388 ms
64 bytes from ( icmp_seq=4 ttl=52 time=348 ms
64 bytes from ( icmp_seq=5 ttl=52 time=309 ms

Is there a solution to my problem? Or does Spacebridge currently only work with the Hologram Nova?

I was able to resolve the issue by setting wwan0 (the modem interface) as the default route.

Get the gateway IP:

ip route show dev wwan0

Delete existing default route:

ip route del default

Add new default route:

ip route add default via <gateway_ip> dev wwan0

Now everything works as expected and I can establish a tunnel. Leaving this here in case it’s helpful for anyone else.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.