'sudo hologram receive' not recieving messages

Hi all,

I’m trying to receive messages from my R410 Modem using the Hologram CLI. I’m able to run sudo hologram receive -vv (thanks for the verbose tip, @Reuben :slight_smile: ) and can see the TCP socket opening up successfully through the AT+USOLI command on port 4010.

When I send a message, however, from the Hologram Dashboard (under the Messaging tab, Cloud Data on Port 4010 using TCP), I don’t get any response while the expected behavior (I think) should be some kind of +UUSOLI message indicating receipt.

Is there some additional configuration I need to do? Thanks in advance :slight_smile:

EDIT: I tried the webhook url (i.e. curl POST according to this post, is successful) of my device but am still not seeing response from the modem :frowning:

EDIT2: I tried an SMS from dashboard while running sudo hologram receive --sms --modem nova, still not getting a response

Try disabling eDRX on the board. Sometimes that can cause problems with receiving data packets since the radio is off for a longer period of time.

1 Like

I tried the following sequence of commands:


Running AT+CEDRXS? on modem reboot showed that eDRX was disabled for WB. Still wasn’t able to see anything at the receiving port.

I disabled eDRX for the other RATs and still couldn’t see anything on the receiving port.

Do you know of any other possible causes?

EDIT: I tried another modem I had and it seems to be working! Followed the above series of commands - not sure what was going on with the first modem I had…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.