Teeny tiny battery jumpers on Dash


#1

Can you let me know the spec/part number for those insanely small battery jumpers on the Dash? I had one where the inner connector came out of the shroud and then disappeared in the carpet. I am using a full-sized jumper, but it’s not terribly secure. The Digikey part number would be the best.

BTW - the jumper on the bottom does make this awkward to breadboard. I have ended up using some riser sockets to keep the jumper from contacting the breadboard. Also, having to plug and unplug the unit to change from battery to USB is a pain.

BTW2 - Battery mode doesn’t seem to be working. Further troubleshooting needed on this.

Thanks!


#2

To answer my own question on the jumpers, the spec is:

Gender: Female Sockets
Number of Positions or Pins (Grid): 2 (1 x 2)
Pitch: 0.050" (1.27mm)
Height: 0.217" (5.50mm)

Here is the Digi-key page for them: https://www.digikey.ca/product-search/en?keywords=952-1729-ND

I ordered the ones with the little handle to make them easier to manage.

Still need further testing to see what the issue is with the battery mode not working.


#3

Oops, sorry we missed this post. You were really close but the Digikey product number is actually 952-1727-ND. I think your version will work too, it just has the extra handle at the top of the jumper (which probably makes it easier than the ones we’re using)


#4

P.S. We’re working on eliminating jumpers from the design. Totally agree that they get in the way and are inconvenient.


#5

Thanks! I like the little extra handle since I can barely see these things! :open_mouth:

The issue with the jumpers is especially the one on the bottom. If the functionality could at least be consolidated to a single jumper on the top that would be an improvement - or even a small DIP switch.

So far I haven’t been able to get the Dash to run on battery, but I need to do more testing and re-review the documentation/discussions so I can describe the issue better.


#6

Hi Reuben - I can confirm that when I put the jumpers into battery configuration per the illustration in the hardware guide the board won’t power on. I have a LiPo battery outputting 3.4 VDC. I have tried connecting the battery directly and I also have run the battery through a step up converter to bring it up to 5VDC and no result.

Any ideas why this wouldn’t be working? Seems to be fine with my Arduino Mega + ESP8266 combo.

Thanks!


#7

Hmm, so the batteries we sell and test with are 3.7V so I wonder if 3.4 is too low, at least with however much power is left in the battery you’re using. I also wonder if using the step up convertor would interfere with the board’s own battery charging circuit.
Very hard to say for sure though. Is the battery definitely fully charged?


#8

Definitely fully charged. Can I do VIN 5VDC on any of the pins similar to Arduino? I wasn’t clear from the pinout diagram if that would work.

Actually, now that I recheck the specs it is a 3.7 VDC battery - 3.7V 8000mAh Li-Po Polymer Rechargeable Battery. Here is one on eBay:

Works great with my Arduino Mega and ESP8266!


#9

The step up converter is this:

This is what I use for charging:

http://www.ebay.ca/itm/10pcs-5V-Mini-USB-1A-Lithium-Battery-Lipo-Charger-Module-for-Arduino-FA-/361171471926?hash=item54177f4e36:g:buoAAOSwc3ZUpjqm


#10

Oh ok, so you shouldn’t need the convertor. 3.7V battery is enough.

You can do 5V DC in on the 5V pin just like Arduino. Seems like everything you’re doing is correct. Does the board power on when you have battery + USB?


#11

I haven’t tried that yet. What would the jumper setting be for that?

Busy tonight so I will need to check the 5VDC input tomorrow.


#12

Same as the battery setting. That setting allows you to use USB and the battery. It’ll actually charge the battery off of USB and allow you to use USB serial and everything.
BTW, are you on the Pro or the regular?


#13

Just tried that quickly - Nuthin’, nada. It no work.


#14

Switch back the jumpers and plug it into USB and it fires right up - without the battery.


#15

You may have missed my question above, was asking if you had a Pro or a Regular.

We do a battery test on every board, it’s possible that your board had some defect that we missed. Might need to swap it out.


#16

Sorry, I thought I had posted the answer to that! It is a regular Dash and not a Dash Pro.

I will try to test it just using the 5VDC in tonight. Do I need to reset the jumpers to battery mode to use that? Not sure what is going on since everything else seems to be very solid with the board. Seems a shame to have to swap it out. If you had something that was a beta of the next version of the board I’d be happy to be a guinea pig for it.


#17

For 5V only, you would run in the non-battery mode


#18

OK, I’ll give it a shot later on today. Thanks!!


#19

You’re welcome, and in case you didn’t get a chance to find the exact pin yet, it’s L01.


#20

@Reuben & @torchris,

Hey, guys, just what I hope is a helpful note here (don’t want to muddy the waters too much…). I’ve had my Dash fully charge the battery, then run down over the next hours, losing 4-5% per hour, this with no interruption in 5V USB supply. Eventually, Dash shuts down. I’ve measured the battery voltage (disconnected) after this happens; I see about 3.05V on the 2000 mAh (manufactured by PK Cell). When the battery and 5V are disconnected, plugging them both back in seems to jumpstart the Dash, and it eventually charges to 100% (before discharging again). Either way, the battery does reach a level where the Dash doesn’t boot (although in my case it’s a lower voltage than what Torchris is seeing @ 3.4V.

FWIW, I have one of those nifty in-line USB power meters: The Dash draws a pretty steady 0.46A at 5V.

Both Dash jumpers are set to “battery” – over the pins closest to the power connections.