Teltonika FM36M1 not working with Hologram 4G


#1

Hello,
We are testing a Teltonika FM36M1 LTE unit with the Hologram SIM. The device is not connecting to a cellular network. We have applied the correct APM (hologram), but it never connects to a data session. However, if we set the device up touse 2G only, it will connect to the T-Mobile network.

If we change sim cards and stick an ATT sim into it and change the APN, it will connect just fine.

Anyone have any thoughts as to why this device will not connect to Hologram 4G? I’m stumped…


#2

I connected via serial, and this is what I am seeing:
[2019.04.15 17:53:49]->> OKrser] Not Registered, But searching for OP
[2019.04.15 17:53:59]->> +CREG: 2,2ait for registration confirmation from CREGRESET:1e.d: 5 sec
[2019.04.15 17:53:59]->> OKrser] Not Registered, But searching for OP
[2019.04.15 17:53:59]->> +CGREG: 2,4
[2019.04.15 17:53:59]->> OKrser] Not Registered, But searching for OP
[2019.04.15 17:54:09]->> +CREG: 2,2ait for registration confirmation from CREGRESET:1e.d: 5 sec
[2019.04.15 17:54:09]->> OKend] No sending procedure in 135280439 sec, configured period: 5 sec
[2019.04.15 17:54:09]->> +CGREG: 2,4
[2019.04.15 17:54:09]->> OKrser] Not Registered, But searching for OP
[2019.04.15 17:54:19]->> +CREG: 2,2ait for registration confirmation from CREGred period: 5 sec
[2019.04.15 17:54:19]->> OK194C.GPS.INFO] tered, But searching for OP
[2019.04.15 17:54:19]->> +CGREG: 2,4
[2019.04.15 17:54:19]->> OKrser] Not Registered, But searching for OP
[2019.04.15 17:54:29]->> +CREG: 2,2ait for registration confirmation from CREGred period: 5 sec
[2019.04.15 17:54:29]->> OKrser] Not Registered, But searching for OP
[2019.04.15 17:54:29]->> +CGREG: 2,4
[2019.04.15 17:54:30]->> OKrser] Not Registered, But searching for OP
[2019.04.15 17:54:40]->> +CREG: 2,2ait for registration confirmation from CREGred period: 5 sec
[2019.04.15 17:54:40]->> OKrser] Not Registered, But searching for OP
[2019.04.15 17:54:40]->> +CGREG: 2,4