Timeout error on spacebridge

I’ve looked around at the different guides and have been unable to get a connection over space bridge to ssh into my RPi. When I try to connect using Spacebridge I get a timeout error and am unable to proceed. For reference, I’ve been following the guide “Spacebridge for beginners” and am unable to do step 6. (Can’t post links for some reason)

I’m able to send messages from the RPi to Hologram and I’m able to connect to cellular.

I’m using the Nova, which is connected to a RPi Zero W.
I’ve made sure to:

  • Enable tunneling from the Hologram.io dashboard for the appropriate SIM
  • Disable WiFi on the RPi Zero W
  • Run “sudo hologram modem connect” on the RPi Zero W and successfully create a PPP session (could do “ping -c3 hologram.io” with no errors)
  • Download and use the space bridge client for Mac

I’d appreciate any help I can get!

Best wishes,
Blas

The guide I’ve been following is: https://support.hologram.io/hc/en-us/articles/360035212654-Spacebridge-for-beginners

And the error text I get from space bridge when I run it on my Mac is:
Error: *** Failed to connect to tunnel.hologram.io:999: error(60, ‘Operation timed out’)

You configured keys to use with spacebridge as outlined here? https://www.hologram.io/guides/secure-tunneling-with-spacebridge

Thats probably not the case as you aren’t getting authentication rejection errors but wanted to make sure that part was also taken care of. Also that link has a method for trying without the client so its worth trying that to make sure something isnt wrong with the client itself.

I’ve been following the guide for establishing a tunnel with the space bridge client, should I skip using the client and do it manually?

Its worth a shot to just eliminate any possible issues. The client should work but its worth trying just to eliminate it as a possibility.

So I’ve generated the keys and in the process of uploading the public key, this is what I get from running the command:

PUBKEY=$(cat spacebridge.key.pub); curl -X POST -H “Content-Type: application/json” -d “{“public_key”:”$PUBKEY"}" “https://dashboard.hologram.io/api/1/tunnelkeys?apikey=|myAPIkey|
curl: (6) Could not resolve host: |Begining characters in pub key|
curl: (3) unmatched close brace/bracket in URL position 33:
|my computer|.local}
^
{“success”: false, “error” :“Parsing JSON input to API failed. Check that input is valid.”}

Could you please help shed some light on how to resolve this?

Looks like you have an issue with the quotation marks so the command is getting messed up. Do you see where you used double quotes around the the -d parameter? Try changing to single quotes so it looks like this:

'{"public_key":"$PUBKEY"}'

That seemed to solve that problem, thank you!
I seem to get invalid public key as an issue, should I try recreating the keys?

PUBKEY=$(cat spacebridge.key.pub); curl -X POST -H “Content-Type: application/json” -d ‘{“public_key”:"$PUBKEY"}’ “https://dashboard.hologram.io/api/1/tunnelkeys?apikey=|myAPIkey|

{“success”:false,“error”:“Invalid public key”}

EDIT: I tried deleted and recreating the keys, still had the same issue.

Before we go more down this path, would you mind trying again with the original client? We’ve actually been doing some improvements in this area and just released some fixes to our backend systems that might end up solving your main problem.

Just gave the main client a shot, still seem to get the same error:
Error: *** Failed to connect to tunnel.hologram.io:999: error(60, ‘Operation timed out’)

Could issue with the public key generation be due to Mac differences?

Can you see if the keygen command generated an ssh-rsa key?

I’m still not sure on these timeouts. Seems odd. Is it possible that the Mac firewall is blocking connections from the Spacebridge application?

I ran this command as specified in the guide:
ssh-keygen -f spacebridge.key -b 4096

the spacebridge.key.pub file looks like a public key to me. I have firewall turned off for outgoing connections, but would there be a better way to make sure?

I also tried running the spacebridge client on windows and got this:

could this be a signal issue on the RPi side? I’m getting signal values of 24,99

No, it’s very strange. Seems to indicate that you can’t connect to our spacebridge server to establish the tunnel first.
Not sure why that is yet. Everything is up and we’ve confirmed things are working. We have other customers using it fine right now.

For the public key thing, does the string “ssh-rsa” actually appear in the text? That’s what the API is looking for

Yep, that’s the first thing that appears is “ssh-rsa”. It seems like the very end is “== |my computer|” not sure if that’s causing any issues.

I’m just not sure why that it isn’t working with the client and without the client. Would it be better to set up a meeting to try to resolve this issue?

It would be interesting to try it if you remove the |my computer| and replace with a single word like test or something. Don’t remove the == as that’s part of the base64 encoding of the key.
Might do a ticket with support to investigate further.

Changing it with test didn’t seem to help, I’ll try to send a ticket to support!

This topic was automatically closed after 30 days. New replies are no longer allowed.