trouble imitating AT command sequence in "hologram receive"

Hi all,

I’m trying to imitate the AT command sequence as displayed by “sudo hologram receive -vv” using my own python script. My python script is being used to prototype a C firmware driver that will communicate with a SARA R410 modem (same one used in the Nova) over UART.

When I run “sudo hologram receive -vv”, I’m able to successfully receive messages sent from the cloud. However, when I run the following AT command sequence generated by the above command:


either using my script or via manual entry over screen /dev/ttyUSB1, I don’t get back any URCs (not even a +UUSOLI URC). I also used the AT+USOCTL command to check the port status but there seems to be no data available.

Something interesting I did notice was that when I run “sudo hologram receive -vv”, I get the following URC: +UUSOLI: 1,"",50814,0,"",40.. The latter socket 0 listening on port 4010 corresponds to the above AT command sequence but I don’t see where socket 1 listening on port 50814 comes from. Additionally, all inbound traffic comes from socket 1 and not from socket 0.

My initial guess is that there’s probably some other commands being issued to the modem that I’m not seeing, like in one of the chatscript files.

Any ideas? Thanks :slight_smile:

That’s not two sockets, that’s showing the remote IP and local IP for the same socket.


Yup, my mistake. Thanks.

I thought there was a second port open because I saw hologram receive attempt to close Socket 1 when it had just opened up a TCP Socket on Socket 0.

I’m still not able to get the +UUSOLI URC with the manual commands via screen. Are there any other commands that should be issued other than the ones I’ve mentioned above?

EDIT: made a silly mistake, forgot to issue a USOCO=1,"",9999 in addition to the listening socket.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.