Unable to connect Hologram Network from Raspberry Pi 3


#1

Hi Guys,

I am working on a project which requires to enable the Internet connection through the cellular network with Hologram NOVA and its SIM card. I am at the stage where I have activated my SIM card on the dashboard but it keeps saying ‘Live’ instead of ‘Connected’. I tried to use the SDK that “hologram.network.connect” but it keeps giving me the error “ImportError: cannot import name Timeout”. Can anyone help ASAP? I will be really appreciated!!


#2

Sounds like you dont have the required python libraries installed. Try re-installing the python SDK / CLI per: https://hologram.io/docs/reference/nova/user-manual/

and check for any errors during installation.


#3

Thx! But I just tried it again it still gives the same error.
I ran this command " curl -L hologram.io/python-install | bash" in Raspberry Pi terminal and it shows that “You are now ready to use the Hologram Python SDK!” However, when I ran this code “sudo hologram connect” and the terminal still gave me the error:
" from serial…serialutil import Timeout
ImportError: cannot import name Timeout"


#4

Is it due to any possible bugs like APN configuration or the OS system or even SIM card itself?


#5

No that’s definitely a python error


#7

Is it due to the python installed on the raspberry pi?


#8

Is this a fresh install of raspbian or have you changed anything?

One thing to try is sudo pip install pyserial and then try running it again


#9

It is Raspbian Stretch: raspbian-2017-07-5 I installed.


#10

I just tried “sudo pip install pyserial” and it returned “Requirement already satisfied”


#11

That’s a very old version of raspbian. Have you run an update recently?


#13

I just checked the raspberry Pi version:
PRETTY_NAME=“Raspbian GNU/Linux 8 (jessie)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“8”
VERSION=“8 (jessie)”
ID=raspbian
ID_LIKE=debian
HOME_URL=“http://www.raspbian.org/”
SUPPORT_URL=“http://www.raspbian.org/RaspbianForums”
BUG_REPORT_URL=“http://www.raspbian.org/RaspbianBugs”


#14

Yeah that’s really old. Can you try a sudo apt upgrade

If that doesn’t work, try apt-get


#15

Ok, will do! Thank you so much!


#16

Hi i did the upgrade but the software version still shows up as before. Is there any other way to upgrade?


#17

Did it install anything when you ran the upgrade?

You can see if that helped.

Otherwise best thing might be to grab the latest Raspbian image and try with that. Newest is from November 2018 I think


#19

Hi Reuben,

My previous account reached to the limit today. I just re-do everything and it all work until I tried to connect to the network with the command “sudo hologram network connect”. It gives the following result. Why it failed to start PPP

sudo hologram network connect -v
INFO: Detected modem NovaM
INFO: found working port at ttyUSB1
INFO: chatscript file: /usr/local/lib/python2.7/dist-packages/Hologram/Network/Modem/chatscripts/default-script
INFO: Instantiated a NovaM interface with device name of /dev/ttyUSB1
INFO: Connecting to cell network with timeout of 200 seconds
INFO: Checking for existing PPP sessions
INFO: Starting pppd
ERROR: Modem hangup - possibly due to an unregistered SIM
INFO: Failed to connect to cell network
Failed to start PPP


#20

I’m having this same exact issue. Followed the instructions to a T. I’d say I registered the sim about 4 hours ago.

All I see on the modem is a solid blue. Other commands that involve using the network don’t work either.

Also after it just sitting there the blue light went off and this popped up when trying to connect:

Unable to detect a usable serial port

unplugging and plugging back in solved that. but still having above error.


#21

Glad you got the python issue fixed. You guys should check out the Cat-M thread: Nova R410 Issues (Troubleshooting tips and tricks and known issues on the R410 Nova + user feedback on issues)


#22

Thx for your help! Your awesome advice is right ontp the point!

I wonder whether I can use any other LTE modem but with Hologram SIM card to connect to the cellular network. If so, how complex is the configuration/setup


#23

Ok. So running this command gave me a solid red light within the first 2 min of modem boot.

AT+URAT=7


So now I have a solid red and blue light now.

But same error:

ERROR: Modem hangup - possibly due to an unregistered SIM
DEBUG: Killing pppd
INFO: Failed to connect to cell network
Failed to start PPP


BUT! I can now send messages just fine. :stuck_out_tongue: Strange