Unable to Connect Hologram

I am unable to connect out device to the cloud using

sudo hologram modem connect -v

Currently the error I am getting is,

pi@raspberrypi:~ $ sudo hologram modem connect -
Note: “hologram modem connect” is deprecated in favor of “hologram network connect”
INFO: Detected modem NovaM
Error: Unable to detect a usuable serial port

did you try performing the action from the depreciation message?

Are you doing anything with the Nova before trying to connect? The 410 only has a single serial port so anything using that port during this process will cause it to fail

I have the error I now receive is

pi@raspberrypi:~ $sudo hologram network connect -v
INFO: Detected modem NovaM
ERROR: Unable to detect a usable serial port

what have you all tried already?

Did you unplug and plug the modem back in?
Are the leds on and blinking or solid?

So we have tried rebooting the RPi 3, unplugging the Nova SARA R410M and plugging it back in. The blue light and red light are both solid, the blue comes on first and the red comes on about 5-10 seconds later after plugging it in.

Hi there. Do you get that error message right after a reboot or does that only happen when you have run other commands first?
Also, if you run with -vv (instead of -v) it’ll have a little more information for debugging that could be useful to post.