USB port w/ SARA-R410M modem

Using a Raspberry Pi 4 and after powering up and trying to use the modem I get the following error:
“Unable to detect a usable serial port”
If I unplug the modem, then just plug back in it works fine (after killing any PPP sessions)
I’ve tried resetting the USB ports via python and no joy.
Also have cycled the USB power via programming with no result.
Any ideas on how to solve this issue?
I’m trying to use this for remote data acquisition on a timer that powers the Pi up and down occasionally so manually unplugging the modem is not possible in actual usage.

I’ve run into this as well with the 410. I have been able to recover by rebooting the Pi (sudo reboot) but I will try to find a better workaround for you.

Hi, a couple things to check:
Make sure no modem manager is running.
Make sure PPP is stopped.
I think some older firmware versions had this issue when on AT&T so you may want to upgrade the firmware.

You said you only reset it with Python, what is the underlying method your python lib uses to do the reset? Have you tried uhubctl (https://github.com/mvp/uhubctl) to do the reset of the USB ports? I’ve had good results but had to play around with port numbers, afraid I don’t have a working example anymore.

Erik

I’ve generally had a bit of issues with the SARA-R410M Hologram system in terms of reliability. Rebooting the whole CPU obviously isn’t elegant or a reliable solution. However, it sometimes becomes the only easy solution. I think Hologram may want to delve into this and provide some programmatic solution.

I found general success in /usr/bin/usbreset to reset the USB of the Linux hub and also usb_modeswitch

unbinding and re-binding the drivers can work too.

Essentially we are just resetting the USB controller in order to re-access the Nova.

I have also had my modem just turn off, no blue LED or red LED. Sometimes the red LED goes off only. I have no real idea why, I am not performing and over-current activities.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.