Use Nova on Ubuntu VM


I would like to know the required steps to use Nova on an Ubuntu (desktop version) VM created using Oracle Virtual Box. I have the extension packet installed and I can see the Nova being detected with “lsusb” and the 6 ttyACMx ports in /dev. But when I tried to use the command “sudo hologram modem connect”, I got an error “Unable to detect a usable serial port”. Any advice will be greatly appreciated!

We haven’t tested that setup before but seems odd that it wouldn’t work.

Did you install the library using pip alone or with our full script?

Can you run the command with -vv at the end to get debug output and paste it here?

One thing to check is if you can send data to the serial port on your own. You can use screen to open up the port and then try typing AT and see if the modem responds with OK.
(To exit screen, do ctrl-a k)

Hi Reuben,
Thank you for your reply. I install the library using the curl command (curl -L | bash).
As for the debug output, I tried many times. Sometimes it is actually able to connect (everything fine), but other times it is just sending AT to a serial port, getting no response, and then moves to the next port, until it has tried all ports and showed “unable to detect a usable serial port”. So this is weird…maybe something wrong with the ports on VM? Similarly, for using screen, sometimes I can get a response and other times it’s just a dead terminal.

Anyways, my team has decided to not use this setup so this issue is no longer a concern for us.

Best regards,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.