Using Hologram NOVA with Ubuntu Virtual Boxes

The documents state “The SDK and the CLI only can be run on Linux”. I tried to run it the ubuntu through Virtual box in a windows PC.

I am getting errors when using the SDK and the CLI. Attaching image of the error.

I raised a ticket with hologram support.
They replied " Yes, it is possible to use the SDK and CLI with Ubuntu. However, you will have to share your hardware ports with the container. For assistance with these modifications, posting on our community forum is the best place."

So here I am.

Thanks in advance for the help!


I guess I cannot attach images to the topic.

Error output:

osboxes@osboxes:~$sudo hologram network connect
ERROR: Unable to detect a usable serial port

Can you run that command with verbose output sudo hologram network connect -vv It will give a lot more insight into whats happening.

At first glance its not finding the modem, can you confirm that the hardware ports are accessible in vitual box and that the modem is enumerating in a sane place. ls /dev/TTY*

osboxes@osboxes:~ lsusb Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 003: ID 05c6:90b2 Qualcomm, Inc. Qualcomm CDMA Technologies MSM Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub osboxes@osboxes:~ sudo dmesg | grep ttyUSB
[sudo] password for osboxes:
[ 189.247460] usb 1-2: GSM modem (1-port) converter now attached to ttyUSB0
[ 189.248633] usb 1-2: GSM modem (1-port) converter now attached to ttyUSB1
osboxes@osboxes:~ ls -l /dev/ttyUSB* crw-rw---- 1 root dialout 188, 0 Jul 29 17:59 /dev/ttyUSB0 crw-rw---- 1 root dialout 188, 1 Jul 29 17:59 /dev/ttyUSB1 osboxes@osboxes:~ sudo hologram network connect
ERROR: Unable to detect a usable serial port
osboxes@osboxes:~$ sudo hologram network connect -vv
DEBUG: checking for vid_pid: (‘12d1’, ‘1506’)
DEBUG: checking for vid_pid: (‘12d1’, ‘1001’)
DEBUG: checking for vid_pid: (‘05c6’, ‘90b2’)
INFO: Detected modem NovaM
DEBUG: checking port ttyUSB0
DEBUG: checking port ttyUSB1
ERROR: Unable to detect a usable serial port

Hopefully that helps

Interesting, so the devices are there and it sees them.

Can you write to those ports using anything, like screen and confirm that they write back. Thats how the SDK finds available modems is it tries any device matching the hardware ids and sends a simple AT command on each serial port waiting for a OK back. Basically the issue you are having here is that the modem isn’t responding to the AT command.

osboxes@osboxes:~ screen /dev/ttyUSB0 [screen is terminating] osboxes@osboxes:~ screen /dev/ttyUSB1
[screen is terminating]

screen is just terminating immediately

hmm, interesting. Can you try writing and reading from the windows system. I tend to use the arduino serial monitor just cuz its easy but if you have another tool go ahead. I am wondering if there is something blocking the virtual box from being able to read from the serial ports.

I used something called Teraterm. I started it in serial mode to COM11.
Figured out this from the Device Manager window.

Not able to type anything into it though.

I am setting it to the baud rate of 9600. Not sure if I am using the correct baud rate.

9600 should be fine. Are you able to communicate with it when the virtual box isn’t running? The modems are definitely compatible with windows as I wrote the c++ sdk for windows as a side project some time ago.

I am not able to type anything into the serial communication window with the virtual box closed.

Is the C++ SDK for windows available for public use?

its very much a hack week project, it works but its not something we support

Thanks Dom. I will give this try later.

But, for now I would rather stick with a platform something that is supported by Hologram.
So I went ahead and dusted up an old Pi I had. Set it up.

Things are running fine. I am able to use the “sudo hologram modem” commands just fine.
But when I try to use the “sudo hologram network” commands is still throwing the same error “ERROR: Unable to detect a usable serial port”

With the R410 there is only 1 usable serial port so if its tied up doing anything like ppp then it won’t work but that is strange that it would work for one subset of commands but not the other. Do the modem commands work after the network commands stop/don’t work? they both use the same serial port discovery method so I don’t see why one would work and the other wouldn’t.

Hi found the issue. My bad.

I ran another network connect command before disconnecting it. Things are working fine now.

Only issue I have now is:
When I am trying to send SMS from NOVA to my phone, I am getting a return code 48 with no errors. But I am not receiving the SMS on my phone.

Who is your provider? they may not allow international/M2M MSISDNs to send SMSs to you. Its something we have seen before and usually requires talking to your provider

My provider is AT&T. I will call them up.