Using NOVA-U201 with Debian 10 connman/ofono possible?


I’m using NOVA-U201 modem with Beaglebone Black Debian 10 image, it works with ppp software package nicely, CDC-ECM mode is also operational (no ppp software needed, I can manage the interface with ifup/ifdown commands). I didn’t try to use Hologram Python SDK, as it requires Python 3.9, and only Python 3.7 is available in the Debian 10 repos.

But I tried to integrate it with connman connection manager which is installed by default. I also installed ofono plugin (version 1.21 from the Debian repos) to provide cellular modems support for connman, and that’s where something fails.

connmanctl technologies command lists cellular among available technologies, but there is no services (connmanctl services) related to the modem. I think the modem fails to initialize properly with ofono.

Could someone please help me to debug this problem?

I ran ofono -nd to gather debug output, and here are some last lines from the output:

ofonod[2496]: drivers/ubloxmodem/lte.c:ublox_lte_set_default_attach_info() LTE config with APN:
ofonod[2496]: src/modem.c:get_modem_property() modem 0x1629b60 property AlwaysOnline
ofonod[2496]: plugins/ublox.c:ublox_set_online() modem 0x1629b60 online
ofonod[2496]: drivers/atmodem/gprs-context.c:at_cgdata_test_cb() use_atd99:0
ofonod[2496]: drivers/atmodem/sim.c:at_crsm_info_cb() crsm_info_cb: 90, 00, 27
ofonod[2496]: drivers/ubloxmodem/lte.c:ucgdflt_cb() ok 0
ofonod[2496]: src/modem.c:modem_change_state() old state: 2, new state: 3
ofonod[2496]: drivers/ubloxmodem/netmon.c:ublox_netmon_probe() ublox netmon probe
ofonod[2496]: drivers/atmodem/sim.c:at_crsm_read_cb() crsm_read_cb: 90, 00, 29
ofonod[2496]: src/gprs.c:ofono_gprs_detached_notify() /ublox_0
ofonod[2496]: drivers/atmodem/network-registration.c:build_cmer_string()
ofonod[2496]: src/sim.c:ofono_sim_add_spn_watch() 0x161f458
ofonod[2496]: src/network.c:__ofono_netreg_add_status_watch() 0x1625228
ofonod[2496]: src/gprs.c:gprs_netreg_update() attach: 0, driver_attached: 0
ofonod[2496]: src/network.c:ofono_netreg_status_notify() /ublox_0 status 0 tech -1
ofonod[2496]: src/network.c:current_operator_callback() 0x1625228, (nil)
ofonod[2496]: src/gprs.c:netreg_status_changed() 0
ofonod[2496]: src/gprs.c:gprs_netreg_update() attach: 0, driver_attached: 0
ofonod[2496]: src/simfs.c:sim_fs_op_read_block() bufoff: 0, seekoff: 39, toread: 17

The line ofonod[2496]: drivers/ubloxmodem/lte.c:ucgdflt_cb() ok 0 suggests (I’m not sure) that ofono tried AT+UCGDFLT command and it failed, as it’s not supported by SARA-U201 chip in the modem.

Do you have any idea if SARA-U201 is supported by ofono?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.