Voltage divider wiring?


#21

@ Chris, I did not have a DMM on at the time, but I checked immediately after it failed to start and was getting a reading of 6.2volts off the battery pack. It worked of the battery pack all day yesterday as I was testing OTA updating and usage tracking features. I disconnected it from the battery overnight and this all happened this morning when I was setting up for further testing.

@ Mtstarr The battery pack is measuring just a touch over 6.2 volts. I don’t remember exactly, but can check tomorrow. It would make sense if it was a typo and 6 volts was the rated max. 6.2 would probably be enough to overdrive it and cause a premature failure. That may explain why it worked yesterday.


#22

Which version of the Dash do you have? v1.1 or v1.2?


#23

Also the link to the datasheet by @mtstarr is correct, but the absolute max is actually 7V, as listed on page 5 of the datasheet. Not that you should go off that normally, but it’s what the chip should be tested to.

http://ww1.microchip.com/downloads/en/DeviceDoc/20002090C.pdf


#24

I have the Dash v1.2, I checked the battery pack this morning and it is actually outputting 5.92volts currently. I am going to try to setup the voltage divider again today with another Dash to see if I get a repeat of the failure or not. I will probably up the resistor values to lower the current flow, but that should be more about battery life and not frying a board.


#25

I switched to a 1m and a 500k ohm resistor pair for the divider and vout from the divider is 2.02volts. I reconnected the Dash to the battery and it booted and transmitted fine this time. Maybe it was just a bad unit. Going to keep playing around today with battery monitoring.


#26

Great to hear. I will say on my Mac, mine has looked dead to me mostly because of Mac USB ports…

Make sure you are running 1% resistors, not 5% resistors for a voltage test…


#27

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.