Waveshare modems (SIM7080G, etc) with RPi Pico

Hi,

I have been using the Hologram system with the Hologram NOVA USB modem with good success with Raspberry Pi boards. These are, of course, full stack Linux machines, and the connecton is done using the hologram SDK, or otherwise the Python “requests” library.

Due to the impossible availability of the RPi boards (except the Pico), I am now exploring using a Waveshare modem board with the RPi Pico board. This seems to be an excellent match. I’m using the following board with the Pico:

https://www.waveshare.com/wiki/Pico-SIM7080G-Cat-M/NB-IoT

Rather than post lots of code here, I’ve been able to very successfully POST data to Google Apps Script at secure address https://script.google.com. The script updates spreadsheets in the google account. Note that it is a secure https: site, and the modem handles the SSL negotiation required.

When I try to do a post request to https://dashboard.hologram.io, I get a failure to connect (the Waveshare modem says: +CME ERROR: operation not allowed).

Note that this happens at the first connection attempt to the https://dashboard.hologram.io site. This is before authentication, etc. I am well aware of how to get the POST authentication to work. The problem is that the modem and the hologram site cannot negotiate a secure connection (preceding authentication), yet it has no trouble doing so with the secure Google site above.

Using my Chrome browser to go to each of the two sites shown above reveals the following (and I am at the limits of my understanding here!):

https://script.google.com: Public key: ECC (256 bits)
https://dashboard.hologram.io: Public key: RSA (2048 bits)

I am wondering if the hologram site uses an encryption method beyond the capability of this modem? I think the modem may only be able to handle 256 bit encryption.

This is the link for the modem and the relevant pages are 170 to 174.

I am setting up the modem for secure operation for both sites as follows:
# Set SSL version, SSL no verify
send_at(“AT+CSSLCFG=“sslversion”,1,3;+SHSSL=1,”"")

The 3 is as per the following (and works with the google site):
1 QAPI_NET_SSL_PROTOCOL_TLS_1_0
2 QAPI_NET_SSL_PROTOCOL_TLS_1_1
3 QAPI_NET_SSL_PROTOCOL_TLS_1_2
4 QAPI_NET_SSL_PROTOCOL_DTLS_1_0
5 QAPI_NET_SSL_PROTOCOL_DTLS_1_2

I’ve tried all the other settings (1-5) with no success.

The modem has a lot of settings for configuring SSL setup (pages 170-174), but I am out of my depth.

Can someone help me? Has someone got these modems working with Hologram?

Thanks!

Phil

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.