Carriers in Canada

Whelp, Day 3 of trying to figure this all out. Total newbie to using modem modules so go easy. I have two modems:

SIM7000A and SIM800L - Both of which are not getting into a registered status.

Starting with the SIM7000A (The prefered modem) when I can for carriers (COPS=?) I can see both Bell, and Telus. On the SIM800L I can see Rogers. Both modems end up in a Denied state (GREG: 0,3)

I assume the SIM7000A would only report networks that are responding and working with the IoT-M protocols (M1 or NB). There was a thread here that stated all the major carriers (Bell, Rogers and Telus) were supported, but the coverage map only show Rogers (and others not near me). I slapped my Telus data only SIM into this modem and also got a denied state.

The SIM800L while connecting to rogers would still only get a denied state with the hologram SIM.

I’m currently using the FONA library test sketch, so nothing fancy.

The project will be tested in the US, and I see in the forums that I should be OK there - I’d just really like to get the dev work out of the way here before I head down to play.

Any thoughts, suggestions would be welcome. TIA.

I’m assuming you activated the simcard in the hologram dashboard? Did you set the APN correctly on both devices (apn=“hologram”, no username or password). I would also leave the modems (with activated sim installed) up and running for a few hours, and see if they connect during that time. The first registration can take a while (usually less than 15 minutes, but just to be safe leave it for hours). I have seen it take longer if I turn on the modem with a simcard I haven’t activated yet and it gets rejected a few times. Maybe the tower temporarily black lists it or something.

I have a sim800L in Victoria (near Vancouver) successfully connected to Rogers:

From hologram dashboard “inspect”, some fields anonymized:
{"linkid":??????,"record_id":???????????,"session_begin":"2018-07-13 21:32:38","timestamp":"2018-07-13 21:47:27","bytes":1093,"imei":"??????????????","cellid":56423,"lac":9120,"network_name":"Rogers Communication Partnership"}

Lastly, see my post about the series of AT commands I use to setup the SIM800L HERE

Hopefully some of this helps. Sorry I cant offer much on the SIM7000A, I switched to U-Blox for LTE-M1/NB-IOT.

I had seen your post, but didn’t attribute it to Canada, and since I could never register, the APN shouldn’t have mattered?

Well. I have no idea what changed, but magically the 800L is roaming on Rogers.

Couple things

  • SIM was backwards (FML)
  • May have had power issues? Not sure. No reason why I wouldn’t have had enough power
  • Got lucky?
  • CONTYPE commend never worked, always error (doesn’t even show as an option)

Now that this modem works, I can work on getting data posting, even if it’s the wrong modem, and data


As for LTE-M1/NB-IOT what Bands and Carrier are you connecting to? Would be interested to know.

NB-IOT is not yet available in Canada to the best of my knowledge and Bell is supposed to be rolling out LTE-M1 soon. We have been using a unit capable of GPRS/NB-IoT and LTE-M1 in order to be able to test in Canada. If you can check with your unit, you may find you are on GPRS. We are connected to Rogers as well and it is only GPRS that worked for this. One of the things that prevented registration was that the NB-IoT took longer than our modem allowed for a scan, causing timeouts in registering. We are using the BG96.

If you find out otherwise, we would appreciate knowing.

Hope this helps.

Yea good point @longtimer , Currently no LTE-M1 or NB-IOT in Canada.

So currently you are out of luck on the SIM7000A testing until you go to the US.

Awesome. I think I narrowed down my issues.

  1. There’s a power regulator on the SIM900l modem I’m using, and I think it wants upwards of 6.5+ volts to keep the SIM900l powered.

  2. I was able to add a delay call to the Arduino SIMCOM library which kept the watchdog timer happy

  3. It REALLY wants to be a faster bitrate between the controller and modem. 4800 was too slow and commands were getting munched.

Still a handful of errors while sending - but I’ve been able to get it to send a few good times.

As for Iot/M1 - I was shocked that I saw the networks, I assumed those networks wouldn’t have shown up if they didn’t support the protocol.

Thanks for the direction. Now on to the Hologram -> Lambda bits. \o/

Im just guessing but LTE-M1 is basically a software / protocol addition to existing LTE towers, so its possible the broadcast messages for normal LTE are the same / compatible with LTE-M1, but if the tower doesn’t support the bandwidth / protocol / etc. of the modem it probably rejects it. This may be why with an LTE-M1 compatible modem you are seeing towers show up in a scan but none allowing you to connect. Total guess on my part though.

  1. That may be the case, definitely look at the datasheets for the module / shield / whatever you are using. Also note that 2G requires up to a 2A pulse when sending data, make sure your power supply can support that otherwise you may get dropped data, modem restarts, or other undefined behavior. Also be careful with the logic reference voltage of the chips you are using (2.8V for SIM800L) vs the power going into them and the logic voltage of the arduino (I think 5V, maybe 3.3V). Maybe your adapter board / shield accounts for this but that is another thing to double check, if you are sending serial commands at 5V from the arduino to the SIM800L you may damage / break it. If you are using shields its very likely they address this for you.

  2. good to hear

  3. For bit-rate, most of the modems from SIMCOM and other manufacturers default / play nicest at 115200 baud. I would recommend baselining that unless you have other reasons (like if you are using software serial which you should avoid anyway).

Yeah, it’s interesting how the modem saw it, but didn’t react.

  1. I’m using an ESP8266 so 3.3 levels. Arduino is usually 5 but tolerable to 3.3. I’ve put it on my bench power supply, which is how I keep bumping the voltage up. There really isn’t a spec sheet for the breakout board. All kind of why I’d prefer to be using the 7000A.

  2. That’s where I ended up. I think I started at 4800 because of an example I was looking at. But all seems well now.

Thanks for all the comments.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.