Everytime R410 modem takes forever to initialize/connect


#1

Hi,

Living in Ohio(USA) here and the R410 takes a very long time to connect to a network. Is there a way to speed it up? It’s almost useless. I have to wait about an hour each time I plug it in for it to have both red and blue lights illuminated. Only when both lights are on can I communicate. What is going on? Please help. Everything else works so well, it’s amazing.

Thoughts?

-nonoski


#2

checkout the thread Nova R410 (Cat-M) Issues (Troubleshooting tips and tricks and known issues on the R410 Nova + user feedback on issues)

It covers some of the issues you are seeing. That being said it shouldn’t take 1+ hour every time it restarts although it could take a while if it is moved and cannot connect to the same tower or network.

Note with some custom software and AT commands you can speed up registration but with the possibility of restricting the networks you connect to. As one datapoint, I configure my r410m’s to connect only to Verizon cat-m1 towers and let it search for 15 minutes (before hunting for other networks). They usually connect within 2-5 minutes.


#3

Andrew,

Great advice! I’ve disabled the NB-IOT protocol and it’ll connect within 40s! That’s what I need and want. From my research it seems the Cat-m is the way to go anyway. It doesn’t look like the US might even get NB-IOT… Either way, ~1hour does not work for my business… So I think it is good. Can you please explain the command you use for this: “connect only to Verizon cat-m1 towers and let it search for 15 minutes (before hunting for other networks).”

Many thanks!!


#4

The main command you need is AT+UMNOPROF=3 to set the modem to Verizon Cat-M1 mode, see https://www.u-blox.com/sites/default/files/SARA-R4-SARA-N4_ATCommands_(UBX-17003787).pdf page 59. Also note you may need to de-regester and re-boot the module with the AT commands described in 7.15.1. You should only need to do this once per device as the modem keeps track of its profile state between power cycles.

To implement the “wait 15 minutes and then search for other networks” there is no specific set of AT commands for this. I literally wait 15 minutes polling registration state (AT+CREG?) and if not registered I change the UMNOPROF command. Right now I change to AT&T, wait 15 min, change to Telstra, wait 15, then change to 0 (search all networks) and wait 15 minutes… then repeat doubling wait times each iteration.

If disabling NB-IOT alone works for you I would stick with that. It may work for me as well but since I live in USA and am trying to support some deployments in Australia I wanted to explicitly search for Australian networks as its a real pain for me to debug / iterate.


#5

Andrew,

I’ve been playing a little more with the at+cops=? and at+cops? command and I’m really confused. Even with NB-IOT disabled - every once in a while the modem will still take an hour to connect. When I run this command it returns:

at+cops=?
+cops: (2,“Verizon Wireless”,“VzW”,“311480”,8),(1,“310 410”,“310 410”,“310410”,8),(1,“313 100”,“313 100”,“313100”,8),(0,1,2,3,4),(0,1,2)

at+cops?
+cops: 0,0,“Verizon Wireless Hologram”,8

What does all this mean? Ideally I’d like to limit the modem to USA AT&T & Verizon? This thing will be unplugged often and I need it to reliably connect within a minute any time it is plugged in to either Verizon or AT&T. Any ideas how to do this? I’m amazed at how long this thing sometimes takes to connect.

Thanks for your help!

-DJ


#6

Did you read the AT command manual for the COPS command? it spells out the meaning of each field pretty well, I certainly couldn’t explain it any better than the manual. COPS=? shows you which operator towers are nearby and COPS? tells you which operator you are connected to. Basically this shows that there are Verizon towers near you.

You cannot easily limit to AT&T and Verizon you can easily limit to just Verizon (command AT+UMNOPROF=3) or just AT&T (command AT+UMNOPROF=2) but there is no command AT+UMNOPROF=3,2,... where you can specify an ordered list.

Specifying a UMNOPROF value should significantly speed up connection times at the cost of reduced coverage (since if you specify Verizon and only AT&T is nearby you will get no signal).