Having problems connecting to Dash on Windows 10


#1

I just received my and I’m having problems connecting it in Windows through PUTTY. It seems to be working but in my device management it keeps telling that it doesn’t recognize the device and cant find its drivers. Does anyone have any advice in getting started? I also tried connecting to my Beaglebone but soon learned that I have no clue what I’m doing. I should probably mention that I’m very new to this. Thank you everyone. Oh, I should also mention it’s a regular Dash if that helps.


#2

What version of Windows are you on?


#3

I’m using windows 10


#4

Hmm, I’m on Windows 10 and it works without any drivers, but you can try the driver file posted here: https://community.konekt.io/t/driver-for-dash-serial/125/8


#5

I’m still having problems. This is a screenshot whenever I plug the Dash into my computer. Is there a way I could flash the memory and reinstall it?


#6

I am having a similar problem, 2 PCs and the driver does not appear to install. PCs are Win 10 and Win 7 with the same result (see pic). This is on the same Dash.

Tried Reuben’s driver linked in this thread, windows won’t allow install saying there is a newer driver already installed.

Any help, greatly appreciated!

BR/Keith


#7

Keith,

I have had a similar problem with an HP laptop. If I connected the Dash via a hub, it worked just fine. I’m not sure what causes that. It doesn’t even need to be an externally powered hub either. If you have a hub can you try it and see if that makes a difference? If you are using a laptop, would you mind providing the brand and model so we can further research the cause?


#8

It is possible this is a power issue. You can try with a hub or we’ll be adding some USB Y-cables to our store that can be used to supplement power to the boards. It’s kind of a weird thing. Some laptops are totally fine and some just don’t provide enough power to their USB ports.


#9

Harlee,

It looks like Windows is finding the Dash on the USB port, so that is good! If Windows 10 won’t let you use the .inf file provided by Reuben, you can try and install the default driver already in Windows. It is called usbser.sys and is usually in the C:\Windows\System32\drivers directory.

Try this. If you right click on the device (as shown in your screenshot) and click “Update Driver Software…” then select “Browse my computer for driver software” then “Let me pick from a list of device drivers on my computer”, then select the Microsoft device “USB Serial Modem Device”.

Let us know if that gets you connected!


#10

I plugged the device back in my computer, and instead of saying DASH SERIAL unrecognized it’s now saying unrecognized USB device. I haven’t done nothing other than just plug it in.


#11

Did you ever get a chance to try with a powered hub or y-cable?


#12

Powered hub seems to have improved the situation … I am
getting messages from the Dash in the terminal.

However, messages from the terminal are not showing up in
the Konekt Dashboard. Terminal on PC message repeating over and over =

+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem
bootstrapping:
+EVENT:LOG,16,5,DEBUG,6,240000

Note1: 240000 changes, counting up by 10000

Note2: I know that am on the hairy edge of cellular connectivity (probably should have been a Beta tester) … how can I tell if I am connected to a tower?

BR/Keith


#13

I don’t have any Y-Cables, and when attached to my power USB hub it improves, but still can’t PUTTY into it.

Once there are Y-cables available I’ll definitely pick one up.


#14

Hey Reuben, don’t Dash off, I need a some help here!


#15

Haha
So if you’re able to get to the terminal then it sounds like you’ve resolved your driver/power issues.
Can you post the full log?
It does sound like you might just be having trouble getting a cell signal. Antenna connected?


#16

Antenna is connected.

Log from System IC Reset:
+EVENT:LOG,37,5,DEBUG,26,Konekt Dash system init…
+EVENT:LOG,25,5,DEBUG,14,Version: 0.9.2
+EVENT:LOG,47,5,DEBUG,36,Beginning modem bootstrap process…=
+EVENT:LOG,81,5,DEBUG,70,Bootstrapping (1/14): Init modem (can sometimes take several minutes).
+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem bootstrapping:
+EVENT:LOG,15,5,DEBUG,5,60000
+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem bootstrapping:
+EVENT:LOG,15,5,DEBUG,5,50000
+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem bootstrapping:
+EVENT:LOG,15,5,DEBUG,5,40000
+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem bootstrapping:
+EVENT:LOG,15,5,DEBUG,5,30000
+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem bootstrapping:
+EVENT:LOG,15,5,DEBUG,5,20000
+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem bootstrapping:
+EVENT:LOG,15,5,DEBUG,5,10000
+EVENT:LOG,81,5,DEBUG,70,Bootstrapping (1/14): Init modem (can sometimes take several minutes).
+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem bootstrapping:
+EVENT:LOG,16,5,DEBUG,6,120000
+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem bootstrapping:
+EVENT:LOG,16,5,DEBUG,6,110000


#17

Hmm, failures at step 1 are usually caused by the SIM being missing or not inserted properly or by power issues.
Can you try reseating the SIM just to rule that out?


#18

I had a similar problem to this when i tried to use a different antenna, i guess it didn’t like the antenna impedance or something…


#19

*Sigh!

I just received my Y cable, but still having the exact same problems (See photos above). If I plug into my USB 2 slot I get that the USB device isn’t recognized, and if I plug into my USB 3 I get that the DASH device isn’t recognized. And this is using the Y cable I ordered. So instead I decided to use my TTL serial to USB converter, but I’m not getting any information when I PUTTY into it. Maybe I’m using the wrong pinouts for the TX and RX connections but when I go to the instructions it shows for the DASH Pro and I have the DASH. I’m starting to believe that this device was sent to me not working. I hope not as I’m really excited to get programming and learn what this thing can do. Any other suggestions would appreciated or I’m just going to put this up on my shelf to collect dust disappointed.


#20

Hmm, we do test USB serial on every board, but it’s possible that something broke during shipping. Can you contact us at support@konekt.io and we’ll see if we can swap it out for another one?