New version Nova


#1

I have 6 nova modems working on pi’s. The all have a red led in the top left corner and when I plug i in the led goes on. If I have an antenna plugged in after a time the blue led starts to flash. When I make a connection the blue led goes on.

I just received two new nova modems and when I plug it in there is no red led like the old one. Just one blue one and it lights up and no other led comes on. When I do a sudo hologram modem signal I get 99,99.

What should I do?

PS The type command for the new non working one is
Type: Hologram Nova US 4G LTE Cat-M1 Cellular USB Modem (R410)
The type for the working one is Type: Hologram Nova Global 3G/2G Cellular USB Modem (U201)


#2

What version are the new ones you ordered? R410? Those use Cat-M so are a little different. You may want to take a look at the R410 thread here: Nova R410 (Cat-M) Issues (Troubleshooting tips and tricks and known issues on the R410 Nova + user feedback on issues)


#3

Reuben

Dont I need to get a signal first. The modem signal is returning 99,99 on the 410
I can talk to the modem but what do I do if I have no signal?


#4

The signal command may not show a signal while the modem is still scanning for networks which can take a little while with the R410. Take a look at that thread and the doc page linked in there ( https://help.hologram.io/hologram-nova/troubleshooting/r410-cat-m1nb-iot-nova-troubleshooting ) for tips on how to speed it up like turning off NB support.
It sounds like your original modems are U201 2G/3G so you’ll notice some differences in behavior there.


#5

Reuben
The modem is now getting a signal but not connecting. I guess it may take a few hours for the sim to register.

New question I am not using a Pi it is something called a nano pi running debian. I am getting the message
No handlers could be found for logger “pyroute2.netlink.rtnl.tcmsg.common”

I ran sudo pip install hologram-python like you sugested in another post but it did not fix it.

Do you have any sugestions?

Mark


#6

When do you get that message? Just when you run a hologram command?

It’s probably just that your distro has a different routing library that we don’t expect. Probably safe to ignore that message if nothing else is broken. We’ll see if we can try to get rid of it in the next release.


#7

Hello Rebuen Please see pictures attached

Why can’t I make a ppp connection with this modem. It is not the nano pi because when I use the old (201) modem it works.

Mark


#8

Can you try a sudo hologram modem reset wait 30 seconds and then see if it works?


#9

easy peasy


#10

Hello Reuben
That worked. Why…? and when should I do a reset?
Mark


#11

It’s just a weird thing we’ve noticed with Cat-M and the R410. Take a look at the Cat-M/R410 thread for more info there. Cat-M is still in early days and has some odd behavior sometimes.


#12

I’d say that that is worth trying if you have a signal and PPP isn’t working after a couple tries or if it’s taking more than 20 minutes or so to find a tower.


#13

So if this is an inaccessible embedded system , if it fails a ppp connection I should try reset wait and connect again?

Do you know the particular python script that is showing the no handlers error? Can it be fixed by adding a file or directory?

mark


#14

Yeah, that’s probably a good solution for now. To be honest, I’d say that 3G is probably more reliable right now than Cat-M though it should get better on the network side over the next few months.

I’m not sure. I haven’t looked into it too much. It’s possible that we don’t have a root log handler installed for all commands.


closed #15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.