Nova not connecting on Tmobile


#1

Using Nova with RasPi Zero Wireless. Installed SDK, and updated, just to eliminate it as a possible issue.

Running “sudo hologram modem operator” returns:
Operator: T-Mobile

Running “sudo hologram modem signal” returns:
21,2

Running “sudo hologram network connect -v”

INFO: Detected modem Nova_U201
INFO: found working port at /dev/ttyACM0
INFO: chatscript file: /usr/local/lib/python2.7/dist-packages/Hologram/Network/Modem/chatscripts/default-script
INFO: Instantiated a Nova_U201 interface with device name of /dev/ttyACM0
INFO: Connecting to cell network with timeout of 200 seconds
INFO: Checking for existing PPP sessions
Exception in thread Thread-1:
Traceback (most recent call last):
File “/usr/lib/python2.7/threading.py”, line 801, in __bootstrap_inner
self.run()
File “/usr/lib/python2.7/threading.py”, line 754, in run
self.__target(*self.__args, **self.__kwargs)
File “/usr/local/lib/python2.7/dist-packages/Hologram/Network/Modem/ModemMode/pppd.py”, line 109, in connectThreadedFunc
raise PPPError(‘Modem hangup - possibly due to an unregistered SIM’)
PPPError: Modem hangup - possibly due to an unregistered SIM

INFO: Failed to connect to cell network

I have tried with multiple SIMs that I KNOW for a fact are active and work with the MS2131 modem.

Seems to a similar issue to Nova operator choice


#2

I had the exact same problem, related to AT&T problems with their towers in my case. In my case it was random, sometimes AT&T, sometimes stuck on T-Mobile for days despite reboot.
The fix is to force the Nova to use AT&T:

type at
screen returns OK
at+cops=?
screen returns the carriers your Nova can access
at+cops=1,2"310410"
to tell the Nova to use 310410, or whatever is your AT&T carrier

Nova seems to remember, I haven’t seen T-Mobile appear ever since.


#3

Are you utilizing a Hologram SIM?


#4

Yes, with a Hologram SIM. I have two of them, same result until I did that screen command.
In my case it is following a natural disaster where many towers were destroyed and AT&T functioned in “degraded mode” (their words). T-Mobile only offers service in that area as “roaming” – in other words you cannot buy a plan from them for that area.


#5

Awesome! I will try that and keep you informed!


#6

Soooo not great…

Running “at+cops=?” returns:

+COPS: ,(0-6),(0-2)

This will occasionally return a list of networks, but it’s only about 1 out of 10 times.

Running “sudo hologram modem operator” returns a network name, but it won’t connect to it, same output:

File “/usr/local/lib/python2.7/dist-packages/Hologram/Network/Modem/ModemMode/pppd.py”, line 109, in connectThreadedFunc
raise PPPError(‘Modem hangup - possibly due to an unregistered SIM’)
PPPError: Modem hangup - possibly due to an unregistered SIM

I know for a fact the SIM is registered, and we have 4-5 bars of coverage with at least two of the listed networks at the location of testing.


#7

at+cops=? only works some of the time. When it works make sure you write down the code of the operator you wish to permanently connect to.

then it is the same problem with
at+cops=1,2"310410" (where 310410 is whatever operator you choose)
you need to do it a few times before it “sticks”.

Until you get the above command working, you are going to pound your head against the wall with the errors you reported, I’m afraid.

But once you get past that, mine is now stuck on AT&T, my only reliable operator.


#8

No joy. We’ve tried multiple SIMs, even a non-Hologram one (after changing the APN in the chatscript) and nothing.

Have tried
at+cops=1,2,“310450” (where 310450 is the operator I want)
many, many times. ERROR is the only thing it ever returns.

Maybe thinking I either have a bad modem, or that we just won’t use the NOVA until they can work the bugs out…


#9

just in case… typo:
at+cops=1,2,“310450”
should be
at+cops=1,2“310450”
no comma…


#10

I think I had problems leaving out the comma after the 2

https://community.hologram.io/t/data-usage-and-at-cops/1543

Page 8 of the TELIT document

AT_Commands_Reference_Guide_r0.pdf

shows AT+COPS=1,2,“wanted carrier number”

I would like to be able to define the carrier I want to use without incurring significant data charges.


#11

Correct, the comma is necessary. If you try the command without the comma, all you get is ERROR.


#13

You should double check your MCC and MNC, unless the provider you want is Viaero?

Which Nova are you using the 4G NB-IOT sample or the 2G/3G one?


#14

Viaero is the preferred network, yes. T mobile has poor signal in our area, and Viaero has a much stronger singal quality.


#15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.