NovaM_R404 USB modem on Jetson Carrier: ERROR: Unable to detect a usable serial port


#1

I successfully installed the packages but when I try to send the test message I get

ERROR: Unable to detect a usable serial port

nvidia@tegra-ubuntu:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 05c6:90b2 Qualcomm, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

already tried :
sudo modprobe option
sudo sh -c ‘echo -n 05c6 90b2 > /sys/bus/usb-serial/drivers/option1/new_id’

but still no luck.
I have registered the SIM card on the dashboard and its live.


Spacebridge ssh tunneling: ssh_exchange_identification: Connection closed by remote host
#2

I get the same error message if I have tried to connect using sudo hologram modem connect -v but the modem was already connected or did not connect correctly the first time for some reason. For example, see below, where I connect to PPP, then try to connect again (while I am already connected):

pi@raspberrypi:~ $ sudo hologram network connect -v
INFO: Detected modem NovaM
INFO: found working port at ttyUSB1
INFO: chatscript file: /usr/local/lib/python2.7/dist-packages/Hologram/Network/Modem/chatscripts/default-script
INFO: Instantiated a NovaM interface with device name of /dev/ttyUSB1
INFO: Connecting to cell network with timeout of 200 seconds
INFO: Checking for existing PPP sessions
INFO: Starting pppd
INFO: Successfully connected to cell network
INFO: Adding routes to Hologram cloud
INFO: Adding system-wide default route to cellular interface
PPP session started
pi@raspberrypi:~ $ sudo hologram network connect -v
INFO: Detected modem NovaM
ERROR: Unable to detect a usable serial port
pi@raspberrypi:~ $

If I already have a connection and I sudo hologram network disconnect -v, then it will output that it found an existing connection and will kill the pid. If there is no connection, then the output will simply say checking for existing ppp connections and nothing else.

Also, just to be clear, to send a message from the command line with sudo hologram send "message" does not require connecting to ppp with sudo hologram network connect, and will fail with the same “unable to detect a usable serial port” error. You should not “network connect” before using “send” commands. This was not totally clear to me the first time I went through the instructions.

If already connected, sudo hologram network disconnect before you use the “send” command.

Hope this helps.


#4

I’m not familiar with the Jetson Carrier. Given your post it sounds like you are running a Linux distro. Have you tried watching /var/log/syslog while you insert the Nova to see what’s going on?

On my Linux distro, when I plug in the Nova (with drivers installed) before long I see four new devices:

/dev/ttyUSB0
/dev/ttyUSB1
/dev/ttyUSB2
/dev/ttyUSB3

Do any new devs appear when you plug in your Nova? If so, have you tried communicating with the Nova to send AT commands and view the responses?

All of these are efforts to determine whether or not your system is able to communicate with the Nova.


closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.