switching from NOVA-U201 to the R410M - Failed to Connect

I am trying to use the nova R410M after using the U201 on a raspberry Pi 3. I was hoping for a simple swap but it seems the 410 doesn’t like me. I am able to run the following:

  • “sudo hologram modem signal”: half the time I get 30,99 and half the time I get the “no usable serial port:” error

  • “sudo hologram modem operator”: I usually get Verizon, but sometimes I get the same serial port error.

  • When everything looks good I use "sudo hologram send “test message”, and I get “ERROR: Failed to connect socket” after a very long timeout

I apologize, I am a python guy and the manual dialing stuff scares the life out of me. Both the R410M and the U201 have their own activated sim card. The network even sees them both online when they are on. When I plug the 201 back in, it works like a charm. Just need to use Verizon for a lot of my units :stuck_out_tongue:

Any help is appreciated!

Few things on this:

  • The R410 only has one serial port, unlike the u201 which has a bunch so make sure you’re not trying to start up PPP or do anything that might tie up a port while trying to run another command.
  • On that same note, if you try to send a message and it fails, sometimes the R410 takes longer to time out the request on the port than our SDK does and so you might need to give it a minute before it clears up again. That’s something we’ll look at in the next release
  • [Edit: Replacing this bullet. Info was not fully accurate]
  • Can you send us an email at support@hologram.io and we can look into your issue with that socket error?

I have emailed support!

Thank you!

I’m having the exact same problem with a SARA-R410M-02B-00 module for a embedded application, so am using AT commands.

  • The module is running firmware version L0.0.00.00.05.06; A.02.00.
  • Currently connected to Verizon.
  • I have RSSIs between -85 to -70 depending on the weather.
  • I’ve tried connecting to other TCP servers using AT Commands (http://tcpbin.org/ was the service I used to test). This TCP echo test worked fine.
  • The dashboard does show activity, and does use data when I try my echo test.

With the SARA R410, I issue the following commands and get the following responses:

//Create the socket.
AT+USOCR=6

+USOCR: 0

OK

//Connect the socket. Takes awhile, then produces the output. As it is a synchronous connect, the port is blocked.
AT+USOCO=0,“cloudsocket.hologram.io”,9999

+CME ERROR: Operation not allowed

+UUSOCL: 0

//Check Socket Error, Error 110 is a timeout.
AT+USOER

+USOER: 110

OK

If I attempt to connect asynchronously, I can still enter AT commands, but the error occurs later. I never get the notification that the socket has connected. To me, it seems like something is going wrong in the 3 way handshake, but that is a complete guess…

Other Commands:
AT+COPS?
+COPS: 1,0,“Verizon Wireless Hologram”,9

AT+UMNOPROF?
+UMNOPROF: 0

I can also netcat directly to cloudsocket…:9999 using my laptop and post messages as my device, so I know the servers are up…

I do have it working at the moment using the Python SDK. I added this logic to my script to check for any open session on error and close them. Otherwise it creates its own session and uses it. Also confirmed it works with spacebridge.

hologram = HologramCloud(credentials, network='cellular')
error_count = 0
while True:

    try:
        status = hologram.network.getConnectionStatus()
         if status == 1:
             print('already connected')
         elif status == 0:
             print('connecting')
             hologram.network.connect(timeout=20)
         else:
             print("reconnecting")
             hologram.network.disconnect()
             hologram.network.connect(timeout=20)

         data = {"your_key":"your_data"}
         data = json.dumps(data)
         recv = hologram.sendMessage(message=data, timeout=10)
         print(str(recv))
         time.sleep(15*60)
     except:
         print("There was an error: Count: "+str(error_count))
         error_count=error_count+1
         hologram.network.disconnect()
         time.sleep(10)

EDIT:
Support also had me run a diag and send it in.

Edit2:
Added the rest of my script

Hi folks, I just posted an update about this issue here: Open Network Issue With Cat-M