Open Network Issue With Cat-M

The Hologram Network Team has identified an issue with TCP settings on the carrier side that only affects Cat-M and only in certain areas and certain carriers with certain servers. We’re working with the carriers to resolve the issue and hope to have more information soon. We appreciate your patience on this and those of you who have submitted diagnostic reports to us as these were helpful to help look into the issue.

In the meantime, there is a workaround to use PPP instead of the TCP stack on the modem itself which is what calling the connect function does. Note that doing this does open you up to the possibility of increased data usage since it may cause extra traffic to be routed over that connection. Just something to be aware of and keep an eye on.

We’ll keep you all posted as we work with the carriers to resolve this issue.

For more information about using PPP for this, one of our community members has a helpful post here: switching from NOVA-U201 to the R410M - Failed to Connect

Also can run sudo hologram network connect and sudo hologram network disconnect

Can you confirm this is isolated to the TCP stack and doesn’t affect the UDP stack on the R410M? My concern is if this is a NAT thing or any issue in the Network Layer vs TCP implementation in the Transport Layer.

Based on our side of the investigation so far, this looks like it should only be an issue with TCP but if you’re noticing anything with UDP please let us know.

Any idea when this issue will be resolved? We can confirm that both Verizon and AT&T are not working in Los Angeles area for AWS cloud. But it works for Azure and GCP.

Yeah, understand the frustration here. We’re still working on it with various partners. Its been a bit of a hassle trying to figure out where across the maze of networks things are going wrong. We are basically zeroed in on a cause though and are pushing for a resolution. We’re hoping to have a more solid update for everyone next week.

Hey folks,
Carriers are working on getting approval to deploy the fix for this, but we’ve found that the newer R410 firmware is able to deal with this network config issue better and fixes the problem.
We’re putting together a Nova R410 firmware updater and hope to have it done very soon. I was wondering if anyone in here would be interested in doing some initial testing of that updater before we deploy it to a wider audience. It runs on a Raspberry Pi that has our SDK installed.
Send me a private message on here and we’ll put you on the tester list.

Oh and to be clear, we are still pushing for the network fix, but this firmware updater might actually get done faster.

Thanks a lot to those of you who helped test the firmware upgrader. This is now ready for use at https://github.com/hologram-io/hologram-tools/tree/master/novaupdate

Take a look at the README file in there for instructions. We’ll be posting a separate thread with a guide about this later today.

This firmware will address the TCP issue that we’re seeing on Cat-M but as I mentioned we are still working with the carriers to address on the network side as well.

This topic was automatically closed after 40 days. New replies are no longer allowed.

The new firmware has resolve connection issue to AWS. However, I am having an issue that mqtt broker has sent a message to the device, but the device doesn’t see the data (polling AT+USORD returns 0 bytes) until a AT+USOWR is performed. Could it be related to this TCP/IP issue? Thanks.

It might not be related as setting “AT+CEDRXS=0” seems to have fixed it for AT&T:

https://portal.u-blox.com/s/question/0D52p00008RlYDrCAN/long-delays-using-sarar41002b-with-att

I am having trouble registering with the AT&T network using a hologram SIM and a Sodaq Ubee R410M-02B with firmware version L0.0.00.00.05.06, A.02.00. I am not sure if it is associated with this issue, but the problem is happening on 2 different modems that were working fine when I last used them two months ago.

I am connecting to the Ubee using a USB to UART board and the M-center application from Ublox. Everything looks great when I first power up the modem - I have 3 bars on the AT&T network and it says the modem is “registered, roaming”. When I send it “AT+CREG?”, I get a “0, 3” response, and the registration switches to “registration denied”. Sending “AT+CEREG?” returns “0, 5” and switches the registration back to “registered, roaming”.

Is this due to the network issue for Cat-M that would be fixed by updating the firmware? Thanks!

0,5 is correct for a Hologram SIM. If you’re still having issues, it sounds like that’s unrelated to the other Cat-M issue so you should open a new thread.

Hello Everyone!

I wanted to follow up on this post and let everyone know that this issue was addressed in ublox’s latest firmware release for the R410. If you haven’t done so yet please update the firmware on your R410 Novas