Using Digi XBee3 with Hologram SIM


#1

It looks like this has been asked several times recently, but how do I connect one of the Digi XBee or XBee3 LTE-M or LTE-CAT1 modems with the hologram network? I have one of each of the 4 cellular modules Digi sells.

For the XBee3’s, I’m seeing exactly the behavior that someone mentioned here: https://community.hologram.io/t/digi-xbee3-modems/2009; the AT&T LTE-M XBee3 module tries for a long time to connect and is eventually denied. The AT&T LTE-CAT1 XBee3 reports “Registering to cellular network” forever.

The earlier Verizon LTE-Cat1 XBee (not XBee3) also reports registration is denied.

The AT&T 3G/2G module connects fairly quickly,


#2

Hey @SDamiano,

I’ve recently seen a surge in popularity with the LTE-M Digi XBee3 featuring the u-blox R420 modem so I decided to do some experimenting on my own. I noticed that the biggest barrier to get this to work quickly and reliably was that the modem would scan both for Cat-M1 and NB-IoT networks. This led to the issues you describe. The way I resolved this was simply turning off NB-IoT. To do so I put the device in bypass mode to get direct access to the modem to send AT commands. I am not sure if turning of NB-IoT can be done via XCTU, but since having some familiarity with AT commands can never hurt I would recommend doing what I did.

Below are the commands I used for this. Also, here is a quick intro to AT commands for those who want to dive deeper into this.

Changing the Radio Access Technology:

The Ublox R410 (the modem on the Cat-M1 Xbee) has both Cat-M1 and NB-IoT enabled by default. We have found that turning NB-IoT off dramatically speeds up connection times.

To query the radio access technology send: AT+URAT?

This should return either 7, 8 or 7 & 8. Here 7 is Cat-M1 and 8 is NB-Iot

To turn off NB-IoT send: AT+URAT=7

Here we are telling the modem we only want Cat-M1

Best,
Maiky


#3

Changing URAT has made no difference for me. I’m still continuously getting creg = 3 (denied).

at+urat?

+URAT: 7

OK
at+csq

+csq: 22,99

OK
at+cops=?

+cops: (1,“310 410”,“310 410”,“310410”,8),(0,1,2,3,4),(0,1,2)

OK
at+creg?

+CREG: 1,3

OK
at+cgdcont?

+CGDCONT: 1,“IP”,“hologram”,“0.0.0.0”,0,0,0,0

OK


#4

Try running the following (just going off of memory, I may be mssing something:

AT+UMNOPROF? //double check what your current profile is. defaults to “0” I think.
AT+UMNOPROF=3 //sets bearer profile to verizon
AT+CFUN=15 //reboot module to apply changes
//try for 10+ minutes, see if it connects.
AT+CGDCONT=1,“IP”,“hologram” //try explicitly setting APN
AT+CFUN=15 //reboot

note the UMNOPROF basically applies a bunch of presets to set the modem into Verizon mode. This sets the URAT, UBANDMASK, APNs, and other things for Verizon. I have had trouble getting the R410 online not in the correct mode for the carrier (same story in Australia with Telstra, had to put it in Telstra profile).

I’m back home tomorrow and will try to look up my full command sequence to initialize the module.


#5

So far, no luck with that approach either.


#6

With the newest firmware update from digi… I can get the network to deny me registration much more quickly.


#7

I’ve spent more time playing with this and I’m getting nowhere. Can anyone who has had success give me more pointers?

I know the hologram sim I have is ok, because it does work fine in a Digi 3G XBee. And I know the LTE-M XBee3 I have is OK because it connects immediately with the AT&T sim from my phone and an AT&T APN. But when I put the Hologram sim into the LTE-M XBee3, no matter what settings I put in, I cannot get a connection. It either denies registration or searches forever. I have the same results whether I’m XCTU and Digi’s API or directly accessing the USB output of the u-blox chip.


#8

Anyone?


#9

I finally got it to work! It turned out that I needed a brand new, never used before SIM card. My testing sim cards which I’ve used with other devices were denied registration. When I put in a never-used card, I was able to register immediately.


#10

Hey @SDamiano,

Glad you got this to work! However, I am curious as to why your other SIM cards were giving you issues. If you don’t mind could you reach out to success@hologram.io with those SIM card numbers so we can look into that for you.

Best,
Maiky