Dash does not appear in USB / port in Macbook or Linux


#1

I have a Dash 1.2 Rev D, a Rev E, and an earlier model with a red jumper. The Rev E has been working fine on my mac for a few weeks. Suddenly, it will no longer appear in the port list when I plug it in the USB port.

ls -al /dev/cu*

Does not show the device. Previously, it did.

I tried my Rev D. No luck.

I tried the old one with the red jumper - it works fine. I can’t use this old one for what I need to do. I need the Rev E working, but the point is: something happened in there.

I think there was a firmware update I agreed to and I’m blaming that in my head at the moment. Could this be the case?

I pulled out a linux box and installed everything on it - same story it seems. I can pick up the red jumper (old one) but neither of the newer ones.

I used a powered USB hub to make sure it was not power. I can load a regular UNO on either machine with no problem. The old red jumper model works fine on both.

I’m stuck. I’ve done everything I know to do and I don’t have a clue what’s going on.

Help.


[Solved] No USB connection after update
#2

Does dmesg report anything useful?


#3

I looked on both machines and have not seen anything I would call useful in dmesg. That is, I saw nothing that appeared related. (Good thinking though.)


#5

Hey Thomas,

The issue you are facing is one that we have seen when your Arduino IDE or your Board Manager are not up to date.

What I would recommend would be to make sure you have the latest available version for both of these.

As an aside, in program mode the Dash is a HID device, so no serial port is seen.

Best,
Maiky