Unable to receive message from dashboard

Continuing the discussion from Message.received handler throwing exception:

I am working on the SARA-R410M and trying to receive messages from the dashboard. I have been made aware there are issues with receiving SMS, so I am now only sending data messages.

When I use the CLI to do:
$ sudo hologram receive
it returns: Ready to receive data on port 4010

When I send a message from the dashboard, it eventually returns:
Failed to connect to device to send message
and the message is never received on the nova (except once it was out of many dozens of efforts which was weird)

When I open a socket and try to popReceiveMessage() in python, it returns:
Exception in thread Thread-2:
Traceback (most recent call last):
File “/usr/lib/python3.7/threading.py”, line 917, in _bootstrap_inner
self.run()
File “/usr/lib/python3.7/threading.py”, line 865, in run
self._target(*self._args, **self._kwargs)
File “/usr/local/lib/python3.7/dist-packages/Hologram/CustomCloud.py”, line 336, in __incoming_connection_thread
recv += result
TypeError: can only concatenate str (not “bytes”) to str

I saw the same issue was discussed in the thread referenced here but the bugfix branch is no longer available and after making sure I have the newest version of the SDK, I still seem to have the issue.

Thank you in advance for any support!
Josh

When you say you have the newest version of the SDK you mean you installed the newest version from pip (the newest release) or the newest develop version from the branch on github? We are still pending on that release but this stack trace is helpful and I will take a look at it on our current development branch.

Dom,

Good point. I am using the newest release version obtained with pip. Mind pointing me in the direction of the most recent develop branch? I will give that a try.

Thanks,
Josh

the develop branch is has been a common topic for me lately haha so can check this thread

1 Like

Makes sense. Seems like a good number of people are looking to get messaging working more reliably on the new modems.

I installed the SDK from the develop branch, but the same issues are persisting. Often there is no indication that the message is received (dashboard returns: ‘Failed to connect to device to send message’) and on the occasions it does seem to go through, the SDK returns “TypeError: can only concatenate str (not “bytes”) to str”

Any other thoughts? I’m sure you know, but it’s crucial for my application that I can message my devices. Thanks!

Have you tried updating the firmware and turning off the low power modes on the R410? Those are both a pretty common issue we run into with the R410. We actually changed the factory settings with new batches of the Nova due to this. Let me see if we have a help desk article about how to turn all that off. If not I am sure reuben has posted it here before about turning off those settings

Here is one example

I had seen that post before and tried it, but my modem is returning an error when I try to change it (attached).
Capture

However, the messages seem to be going through consistently now, even though it still has the bug where it can not concatenate them. Is there anything about the modem being powered on for a while that would make this happen? I didn’t change anything else.

It can take awhile for the modem to scan and attach to a tower. That could be part of it

So I was having a similar issue with a string being read as bytes in my own code after transitioning from python 2 to 3, and so popped the line "result = result.decode(‘UTF-8’) into CustomCloud.py after line 331, and poof, it works!
newline

I know you mentioned this and I am assuming you and your team know about this, but for some reason a fix wasn’t working when I tried the code from the develop branch, so figured I would put it out here for any others having a similar issue.

Best,
Josh