Use own AT&T sim with Nova?


#1

Is it at all possible to use my own AT&T sim? I have 25 modems and I can not use the Hologram sim cards.


Create empty device
#2

Hi! Yes, this is possible. The easy way to think about it is of the 3 offerings from Hologram (Hardware, Connectivity and Cloud) you can use 1, 2 or all 3! We obviously have optimized for everything coming through our services but any combo should work!


#3

Are there some instructions somewhere that tell me how to use this modem with an AT&T sim?


#4

Hey Matt,

While we’d love to try out every SIM, we really need to focus on our offering so that’s what we mostly test and focus on; we just can’t try out every SIM from every provider. I realize saying “it should just work” is not always the case and we are here to help troubleshoot if you run into problems. If you have the modem and the hardware, maybe you could give it a shot and then let us know if you’re having issues?


#5

Hi @mattkb - Can you tell us more about how you’re looking to use the Nova with your AT&T SIM? What type of application are you building and how are you using cellular hardware for your specific use case? As @ChrisGammell mentioned, we definitely want to help best but if you provide some additional info that will help us point you in the right direction. Our Nova hardware is not locked at all to only Hologram SIMs and actually certified with AT&T directly for use with its network. All of the functionality in our Python SDK is open source and here’s a link to a specific chat script you can update in the github to change the APN to AT&T’s or another providers if you’re using an alternative connectivity platform with our Nova hardware.


#6

So I am just trying to, after a setup phase, be able to plug the nova in to a Pi, power the Pi, and the nova provides internet connectivity to the Pi.
I first did

$ curl -L hologram.io/python-install | bash

which ran fine, no errors.
Then I run

$ sudo hologram version

and I get
0.7.1
I have the Nova to were it powers up, gets flashing blue LED, so I run

sudo hologram modem location

then get

ERROR: PDP Context setup failed
Location: Not Available

but when I run “hologram network connectt”, I get the error :

$ sudo hologram network connect
Exception in thread Thread-1:
Traceback (most recent call last):
File “/usr/lib/python2.7/threading.py”, line 801, in __bootstrap_inner
self.run()
File “/usr/lib/python2.7/threading.py”, line 754, in run
self.__target(*self.__args, **self.__kwargs)
File “/usr/local/lib/python2.7/dist-packages/Hologram/Network/Modem/ModemMode/pppd.py”, line 109, in connectThreadedFunc
raise PPPError(‘Modem hangup - possibly due to an unregistered SIM’)
PPPError: Modem hangup - possibly due to an unregistered SIM

Is there something I am missing?

If I can get past this error, the rest can be done easily, IMO.
Thank you,

-Matt

ETA
I run this via serial.

ATDT99**1#
CONNECT
~▒}#▒!}!}!} }4}"}&} } } } }%}&ִ▒9}’}"}(}“W▒▒}#▒!}!}!} }4}"}&} } } } }%}&ִ▒9}’}"}(}"W▒▒}#▒!}!}!} }4}”}&} } } } }%}&ִ▒9}’}"}(}“W▒▒}#▒!}!}!} }4}"}&} } } } }%}&ִ▒9}’}"}(}"W▒▒}#▒!}!}!} }4}”}&} } } } }%}&ִ▒9}’}"}(}“W▒▒}#▒!}!}!} }4}"}&} } } } }%}&ִ▒9}’}"}(}"W▒▒}#▒!}!}!} }4}”}&} } } } }%}&ִ▒9}’}"}(}“W▒▒}#▒!}!}!} }4}"}&} } } } }%}&ִ▒9}’}"}(}"W▒▒}#▒!}!}!} }4}”}&} } } } }%}&ִ▒9}’}"}(}“W▒~~▒}#▒!}!}!} }4}”}&} } } } }%}&ִ▒9}’}"}(}"W▒~
NO CARRIER


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.